Bug 2242248 (CVE-2023-43788) - CVE-2023-43788 libXpm: out of bounds read in XpmCreateXpmImageFromBuffer()
Summary: CVE-2023-43788 libXpm: out of bounds read in XpmCreateXpmImageFromBuffer()
Keywords:
Status: NEW
Alias: CVE-2023-43788
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 2243051 2248828
Blocks: 2240180
TreeView+ depends on / blocked
 
Reported: 2023-10-05 07:08 UTC by Dhananjay Arunesh
Modified: 2023-11-09 08:25 UTC (History)
1 user (show)

Fixed In Version: libXpm 3.5.17
Doc Type: If docs needed, set a value
Doc Text:
A vulnerability was found in libXpm due to a boundary condition within the XpmCreateXpmImageFromBuffer() function. This flaw allows a local attacker to trigger an out-of-bounds read error and read the contents of memory on the system.
Clone Of:
Environment:
Last Closed:
Embargoed:


Attachments (Terms of Use)

Description Dhananjay Arunesh 2023-10-05 07:08:05 UTC
A vulnerability was found in libXpm where a vulnerability exists due to a boundary condition within the XpmCreateXpmImageFromBuffer() function. A local user can trigger an out-of-bounds read error and read contents of memory on the system.

Comment 1 Sandipan Roy 2023-10-10 12:05:29 UTC
Created libXpm tracking bugs for this issue:

Affects: fedora-all [bug 2243051]

Comment 4 Dhananjay Arunesh 2023-11-09 08:21:04 UTC
Created motif tracking bugs for this issue:

Affects: fedora-all [bug 2248828]


Note You need to log in before you can comment on or make changes to this bug.