Bug 2256659 (CVE-2024-0208) - CVE-2024-0208 wireshark: GVCP dissector crash via packet injection or crafted capture file
Summary: CVE-2024-0208 wireshark: GVCP dissector crash via packet injection or crafted...
Keywords:
Status: NEW
Alias: CVE-2024-0208
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 2256660
Blocks: 2256664
TreeView+ depends on / blocked
 
Reported: 2024-01-03 17:00 UTC by Mauro Matteo Cascella
Modified: 2024-01-04 09:15 UTC (History)
0 users

Fixed In Version: wireshark 4.2.1, wireshark 4.0.12, wireshark 3.6.20
Doc Type: If docs needed, set a value
Doc Text:
A flaw was found in the GVCP dissector of Wireshark. It may be possible to make Wireshark crash by injecting a malformed packet onto the wire or by convincing someone to read a malformed packet trace file.
Clone Of:
Environment:
Last Closed:
Embargoed:


Attachments (Terms of Use)

Description Mauro Matteo Cascella 2024-01-03 17:00:40 UTC
GVCP dissector crash in Wireshark 4.2.0, 4.0.0 to 4.0.11, and 3.6.0 to 3.6.19 allows denial of service via packet injection or crafted capture file.

References:
https://www.wireshark.org/security/wnpa-sec-2024-01.html
https://gitlab.com/wireshark/wireshark/-/issues/19496
https://nvd.nist.gov/vuln/detail/CVE-2024-0208

Comment 1 Mauro Matteo Cascella 2024-01-03 17:01:20 UTC
Created wireshark tracking bugs for this issue:

Affects: fedora-all [bug 2256660]


Note You need to log in before you can comment on or make changes to this bug.