Bug 2256654 (CVE-2024-0210) - CVE-2024-0210 wireshark: Zigbee TLV dissector crash via packet injection or crafted capture file
Summary: CVE-2024-0210 wireshark: Zigbee TLV dissector crash via packet injection or c...
Keywords:
Status: CLOSED RAWHIDE
Alias: CVE-2024-0210
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 2256655
Blocks: 2256664
TreeView+ depends on / blocked
 
Reported: 2024-01-03 16:55 UTC by Mauro Matteo Cascella
Modified: 2024-02-01 15:39 UTC (History)
1 user (show)

Fixed In Version: wireshark 4.2.1
Doc Type: If docs needed, set a value
Doc Text:
A flaw was found in the TLV dissector of Wireshark. It may be possible to make Wireshark crash by injecting a malformed packet onto the wire or by convincing someone to read a malformed packet trace file.
Clone Of:
Environment:
Last Closed: 2024-02-01 15:39:47 UTC
Embargoed:


Attachments (Terms of Use)

Description Mauro Matteo Cascella 2024-01-03 16:55:29 UTC
Zigbee TLV dissector crash in Wireshark 4.2.0 allows denial of service via packet injection or crafted capture file.

References:
https://www.wireshark.org/security/wnpa-sec-2024-04.html
https://gitlab.com/wireshark/wireshark/-/issues/19504
https://nvd.nist.gov/vuln/detail/CVE-2024-0210

Comment 1 Mauro Matteo Cascella 2024-01-03 16:56:04 UTC
Created wireshark tracking bugs for this issue:

Affects: fedora-all [bug 2256655]

Comment 3 Michal Ruprich 2024-02-01 15:39:47 UTC
This is fixed in current Rawhide build. Older 4.0.x releases do not have the affected code.

https://koji.fedoraproject.org/koji/taskinfo?taskID=112740312


Note You need to log in before you can comment on or make changes to this bug.