Bug 2263545 (CVE-2024-22119) - CVE-2024-22119 zabbix: stored XSS vulnerability in graph items select form
Summary: CVE-2024-22119 zabbix: stored XSS vulnerability in graph items select form
Keywords:
Status: NEW
Alias: CVE-2024-22119
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 2263546 2263547
Blocks:
TreeView+ depends on / blocked
 
Reported: 2024-02-09 16:42 UTC by Robb Gatica
Modified: 2024-02-09 16:44 UTC (History)
0 users

Fixed In Version: zabbix 5.0.40rc1, zabbix 6.0.24rc1, zabbix 6.4.9rc1, zabbix 7.0.0alpha8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed:
Embargoed:


Attachments (Terms of Use)

Description Robb Gatica 2024-02-09 16:42:20 UTC
The cause of vulnerability is improper validation of form input field “Name” on Graph page in Items section.

https://support.zabbix.com/browse/ZBX-24070

Comment 1 Robb Gatica 2024-02-09 16:42:38 UTC
Created zabbix tracking bugs for this issue:

Affects: epel-all [bug 2263547]
Affects: fedora-all [bug 2263546]


Note You need to log in before you can comment on or make changes to this bug.