Bug 2259483 (CVE-2024-22211) - CVE-2024-22211 freerdp: Integer Overflow leading to Heap Overflow in freerdp_bitmap_planar_context_reset
Summary: CVE-2024-22211 freerdp: Integer Overflow leading to Heap Overflow in freerdp_...
Keywords:
Status: NEW
Alias: CVE-2024-22211
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 2259484 2259485
Blocks: 2259486
TreeView+ depends on / blocked
 
Reported: 2024-01-22 05:24 UTC by Rohit Keshri
Modified: 2024-01-29 05:35 UTC (History)
0 users

Fixed In Version: freerdp 2.11.5, freerdp 3.2.0
Doc Type: If docs needed, set a value
Doc Text:
FreeRDP is a collection of remote desktop protocol library and client software that is both free and open source. An integer overflow within freerdp_bitmap_planar_context_reset results in a heap-buffer overflow. This impacts clients built on FreeRDP. However, server implementations and proxies based on FreeRDP are unaffected. A malevolent server could create a RDPGFX_RESET_GRAPHICS_PDU to allocate buffers that are too small, potentially causing subsequent out-of-bounds reads/writes. It's important to note that data extraction over the network is not feasible; these buffers are utilized solely for displaying images.
Clone Of:
Environment:
Last Closed:
Embargoed:


Attachments (Terms of Use)

Description Rohit Keshri 2024-01-22 05:24:53 UTC
FreeRDP is a set of free and open source remote desktop protocol library and clients. In affected versions an integer overflow in `freerdp_bitmap_planar_context_reset` leads to heap-buffer overflow. This affects FreeRDP based clients. FreeRDP based server implementations and proxy are not affected. A malicious server could prepare a `RDPGFX_RESET_GRAPHICS_PDU` to allocate too small buffers, possibly triggering later out of bound read/write. Data extraction over network is not possible, the buffers are used to display an image. This issue has been addressed in version 2.11.5 and 3.2.0. Users are advised to upgrade. there are no know workarounds for this vulnerability.

https://github.com/FreeRDP/FreeRDP/commit/939e922936e9c3ae8fc204968645e5e7563a2fff
https://github.com/FreeRDP/FreeRDP/commit/aeac3040cc99eeaff1e1171a822114c857b9dca9
https://github.com/FreeRDP/FreeRDP/security/advisories/GHSA-rjhp-44rv-7v59

Comment 1 Rohit Keshri 2024-01-22 05:26:45 UTC
Created freerdp tracking bugs for this issue:

Affects: fedora-all [bug 2259485]


Created freerdp1.2 tracking bugs for this issue:

Affects: epel-all [bug 2259484]

Comment 3 Sandipan Roy 2024-01-24 10:33:00 UTC
I don't understand why its marked as Important with CVSS: 3.7
Rohit, Can you explain a bit!

Also RHEL-7 tracker is created for Y-stream that is not present, only z-stream tracker is present. (eg. RHEL-7.9.z)

Comment 5 Sandipan Roy 2024-01-25 08:56:24 UTC
This vulnerability in FreeRDP, resulting from an integer overflow in certain versions, poses a low severity risk due to several mitigating factors. Firstly, it primarily affects FreeRDP-based clients, while server implementations and proxies remain unaffected. Additionally, the potential for exploitation is limited as it requires interaction with a malicious server, and data extraction over the network is not feasible; the vulnerability pertains solely to image display buffers.


Note You need to log in before you can comment on or make changes to this bug.