Bug 2259489 (CVE-2024-23770) - CVE-2024-23770 darkhttpd: allows local users to discover credentials
Summary: CVE-2024-23770 darkhttpd: allows local users to discover credentials
Keywords:
Status: NEW
Alias: CVE-2024-23770
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 2259490 2259491
Blocks:
TreeView+ depends on / blocked
 
Reported: 2024-01-22 05:55 UTC by Rohit Keshri
Modified: 2024-01-22 05:55 UTC (History)
0 users

Fixed In Version:
Doc Type: ---
Doc Text:
darkhttpd through 1.15 allows local users to discover credentials (for --auth) by listing processes and their arguments.
Clone Of:
Environment:
Last Closed:
Embargoed:


Attachments (Terms of Use)

Description Rohit Keshri 2024-01-22 05:55:27 UTC
darkhttpd through 1.15 allows local users to discover credentials (for --auth) by listing processes and their arguments.

https://github.com/emikulic/darkhttpd/commit/2b339828b2a42a5fda105ea84934957a7d23e35d
https://github.com/emikulic/darkhttpd/compare/v1.14...v1.15

Comment 1 Rohit Keshri 2024-01-22 05:55:53 UTC
Created darkhttpd tracking bugs for this issue:

Affects: epel-all [bug 2259490]
Affects: fedora-all [bug 2259491]


Note You need to log in before you can comment on or make changes to this bug.