Bug 2276810 (CVE-2024-27282) - CVE-2024-27282 ruby: Arbitrary memory address read vulnerability with Regex search
Summary: CVE-2024-27282 ruby: Arbitrary memory address read vulnerability with Regex s...
Keywords:
Status: NEW
Alias: CVE-2024-27282
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 2276811 2276812 2276813 2276814
Blocks: 2276815
TreeView+ depends on / blocked
 
Reported: 2024-04-24 05:08 UTC by Avinash Hanwate
Modified: 2024-07-11 11:48 UTC (History)
1 user (show)

Fixed In Version: ruby 3.3.1, ruby 3.0.7, ruby 3.1.5, ruby 3.2.4
Doc Type: If docs needed, set a value
Doc Text:
A flaw was found in Ruby. If attacker-supplied data is provided to the Ruby regex compiler, it is possible to extract arbitrary heap data relative to the start of the text, including pointers and sensitive strings.
Clone Of:
Environment:
Last Closed:
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2024:3540 0 None None None 2024-06-03 01:16:42 UTC
Red Hat Product Errata RHBA-2024:3577 0 None None None 2024-06-04 07:35:32 UTC
Red Hat Product Errata RHBA-2024:3863 0 None None None 2024-06-12 08:23:21 UTC
Red Hat Product Errata RHBA-2024:3987 0 None None None 2024-06-19 13:54:04 UTC
Red Hat Product Errata RHBA-2024:3996 0 None None None 2024-06-20 01:56:06 UTC
Red Hat Product Errata RHSA-2024:3500 0 None None None 2024-05-30 13:12:42 UTC
Red Hat Product Errata RHSA-2024:3546 0 None None None 2024-06-03 07:15:14 UTC
Red Hat Product Errata RHSA-2024:3668 0 None None None 2024-06-06 08:57:18 UTC
Red Hat Product Errata RHSA-2024:3670 0 None None None 2024-06-06 09:23:27 UTC
Red Hat Product Errata RHSA-2024:3671 0 None None None 2024-06-06 09:48:17 UTC
Red Hat Product Errata RHSA-2024:3838 0 None None None 2024-06-11 19:42:31 UTC
Red Hat Product Errata RHSA-2024:4499 0 None None None 2024-07-11 11:48:04 UTC

Description Avinash Hanwate 2024-04-24 05:08:00 UTC
An issue was discovered in Ruby 3.x through 3.3.0. If attacker-supplied data is provided to the Ruby regex compiler, it is possible to extract arbitrary heap data relative to the start of the text, including pointers and sensitive strings.

https://www.ruby-lang.org/en/news/2024/04/23/arbitrary-memory-address-read-regexp-cve-2024-27282/

Comment 1 Avinash Hanwate 2024-04-24 05:11:30 UTC
Created ruby tracking bugs for this issue:

Affects: fedora-38 [bug 2276811]
Affects: fedora-39 [bug 2276813]
Affects: fedora-40 [bug 2276814]


Created ruby:3.1/ruby tracking bugs for this issue:

Affects: fedora-38 [bug 2276812]

Comment 5 errata-xmlrpc 2024-05-30 13:12:41 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 8

Via RHSA-2024:3500 https://access.redhat.com/errata/RHSA-2024:3500

Comment 6 errata-xmlrpc 2024-06-03 07:15:13 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 8

Via RHSA-2024:3546 https://access.redhat.com/errata/RHSA-2024:3546

Comment 7 errata-xmlrpc 2024-06-06 08:57:17 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 9

Via RHSA-2024:3668 https://access.redhat.com/errata/RHSA-2024:3668

Comment 8 errata-xmlrpc 2024-06-06 09:23:25 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 8

Via RHSA-2024:3670 https://access.redhat.com/errata/RHSA-2024:3670

Comment 9 errata-xmlrpc 2024-06-06 09:48:15 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 9

Via RHSA-2024:3671 https://access.redhat.com/errata/RHSA-2024:3671

Comment 10 errata-xmlrpc 2024-06-11 19:42:29 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 9

Via RHSA-2024:3838 https://access.redhat.com/errata/RHSA-2024:3838

Comment 11 errata-xmlrpc 2024-07-11 11:48:03 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 8

Via RHSA-2024:4499 https://access.redhat.com/errata/RHSA-2024:4499


Note You need to log in before you can comment on or make changes to this bug.