Bug 2267500 (CVE-2024-27355) - CVE-2024-27355 php-phpseclib: denial of service
Summary: CVE-2024-27355 php-phpseclib: denial of service
Keywords:
Status: NEW
Alias: CVE-2024-27355
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 2267501 2267502
Blocks:
TreeView+ depends on / blocked
 
Reported: 2024-03-03 07:57 UTC by ybuenos
Modified: 2024-03-03 07:59 UTC (History)
0 users

Fixed In Version: php-phpseclib 1.0.23, php-phpseclib 2.0.47, php-phpseclib 3.0.36
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed:
Embargoed:


Attachments (Terms of Use)

Description ybuenos 2024-03-03 07:57:36 UTC
An issue was discovered in phpseclib 1.x before 1.0.23, 2.x before 2.0.47, and 3.x before 3.0.36. When processing the ASN.1 object identifier of a certificate, a sub identifier may be provided that leads to a denial of service (CPU consumption for decodeOID).

https://gist.github.com/katzj/ee72f3c2a00590812b2ea3c0c8890e0b
https://github.com/phpseclib/phpseclib/blob/978d081fe50ff92879c50ff143c62a143edb0117/phpseclib/File/ASN1.php#L1129

Comment 1 ybuenos 2024-03-03 07:59:47 UTC
Created php-phpseclib tracking bugs for this issue:

Affects: epel-all [bug 2267502]
Affects: fedora-all [bug 2267501]


Note You need to log in before you can comment on or make changes to this bug.