Bug 2281951 (CVE-2024-31142, XSA-455) - CVE-2024-31142 xen: Incomplete fix for XSA-407 and XSA-434
Summary: CVE-2024-31142 xen: Incomplete fix for XSA-407 and XSA-434
Keywords:
Status: NEW
Alias: CVE-2024-31142, XSA-455
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 2281952
Blocks:
TreeView+ depends on / blocked
 
Reported: 2024-05-20 17:31 UTC by Pedro Sampaio
Modified: 2024-05-20 17:37 UTC (History)
0 users

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed:
Embargoed:


Attachments (Terms of Use)

Description Pedro Sampaio 2024-05-20 17:31:48 UTC
Because of a logical error in XSA-407 (Branch Type Confusion), the
mitigation is not applied properly when it is intended to be used.
XSA-434 (Speculative Return Stack Overflow) uses the same
infrastructure, so is equally impacted.

For more details, see:
  https://xenbits.xen.org/xsa/advisory-407.html
  https://xenbits.xen.org/xsa/advisory-434.html

https://xenbits.xenproject.org/xsa/advisory-455.html

Comment 1 Pedro Sampaio 2024-05-20 17:32:01 UTC
Created xen tracking bugs for this issue:

Affects: fedora-all [bug 2281952]


Note You need to log in before you can comment on or make changes to this bug.