Bug 2283145 (CVE-2024-32976) - CVE-2024-32976 envoy: Brotli decompressor infinite loop
Summary: CVE-2024-32976 envoy: Brotli decompressor infinite loop
Keywords:
Status: NEW
Alias: CVE-2024-32976
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Product Security
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 2276371
TreeView+ depends on / blocked
 
Reported: 2024-05-24 20:49 UTC by Nick Tait
Modified: 2024-06-14 01:48 UTC (History)
4 users (show)

Fixed In Version: envoy 1.30.2, envoy 1.29.5, envoy 1.28.4, envoy 1.27.6
Doc Type: ---
Doc Text:
A flaw was found in Envoy's Brotli decompressor. This flaw allows a remote, unauthenticated attacker to trigger an infinite loop, causing a denial of service.
Clone Of:
Environment:
Last Closed:
Embargoed:


Attachments (Terms of Use)

Description Nick Tait 2024-05-24 20:49:05 UTC
Vulnerability in Brotli decompressor that can lead to infinite loop.


Note You need to log in before you can comment on or make changes to this bug.