Bug 2281986 (CVE-2024-36007) - CVE-2024-36007 kernel: mlxsw: spectrum_acl_tcam: Fix warning during rehash
Summary: CVE-2024-36007 kernel: mlxsw: spectrum_acl_tcam: Fix warning during rehash
Keywords:
Status: NEW
Alias: CVE-2024-36007
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 2281987
Blocks: 2282033
TreeView+ depends on / blocked
 
Reported: 2024-05-20 17:57 UTC by Robb Gatica
Modified: 2024-07-11 13:30 UTC (History)
49 users (show)

Fixed In Version: kernel 5.4.275, kernel 5.10.216, kernel 5.15.158, kernel 6.1.90, kernel 6.6.30, kernel 6.8.9, kernel 6.9
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed:
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2024:4354 0 None None None 2024-07-08 07:12:01 UTC
Red Hat Product Errata RHBA-2024:4365 0 None None None 2024-07-08 11:01:45 UTC
Red Hat Product Errata RHBA-2024:4461 0 None None None 2024-07-10 15:56:40 UTC
Red Hat Product Errata RHBA-2024:4463 0 None None None 2024-07-10 18:17:55 UTC
Red Hat Product Errata RHBA-2024:4494 0 None None None 2024-07-11 09:40:01 UTC
Red Hat Product Errata RHBA-2024:4495 0 None None None 2024-07-11 10:36:32 UTC
Red Hat Product Errata RHBA-2024:4507 0 None None None 2024-07-11 13:30:04 UTC
Red Hat Product Errata RHSA-2024:4211 0 None None None 2024-07-02 08:56:44 UTC
Red Hat Product Errata RHSA-2024:4352 0 None None None 2024-07-08 02:03:34 UTC

Description Robb Gatica 2024-05-20 17:57:10 UTC
In the Linux kernel, the following vulnerability has been resolved:

mlxsw: spectrum_acl_tcam: Fix warning during rehash

The Linux kernel CVE team has assigned CVE-2024-36007 to this issue.

Upstream advisory:
https://lore.kernel.org/linux-cve-announce/2024052025-CVE-2024-36007-052e@gregkh/T

Comment 1 Robb Gatica 2024-05-20 17:57:48 UTC
Created kernel tracking bugs for this issue:

Affects: fedora-all [bug 2281987]

Comment 5 Alex 2024-06-09 17:10:51 UTC
The result of automatic check (that is developed by Alexander Larkin) for this CVE-2024-36007 is: CHECK	Maybe valid. Check manually. with impact LOW (that is an approximation based on flags REMOTE KASAN WARNONLY NETWORK  ; these flags parsed automatically based on patch data). Such automatic check happens only for Low/Moderates (and only when not from reporter, but parsing already existing CVE). Highs always checked manually (I check it myself and then we check it again in Remediation team). In rare cases some of the Moderates could be increased to High later.

Comment 6 errata-xmlrpc 2024-07-02 08:56:40 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 8

Via RHSA-2024:4211 https://access.redhat.com/errata/RHSA-2024:4211

Comment 7 errata-xmlrpc 2024-07-08 02:03:30 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 8

Via RHSA-2024:4352 https://access.redhat.com/errata/RHSA-2024:4352


Note You need to log in before you can comment on or make changes to this bug.