Bug 2278615 (CVE-2024-4029) - CVE-2024-4029 wildfly: No timeout for EAP management interface may lead to Denial of Service (DoS)
Summary: CVE-2024-4029 wildfly: No timeout for EAP management interface may lead to De...
Keywords:
Status: NEW
Alias: CVE-2024-4029
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Product Security
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 2276428
TreeView+ depends on / blocked
 
Reported: 2024-05-02 12:25 UTC by Patrick Del Bello
Modified: 2024-05-02 14:07 UTC (History)
46 users (show)

Fixed In Version:
Doc Type: ---
Doc Text:
A vulnerability was found in Wildfly’s management interface. Due to the lack of limitation of sockets for the management interface, it may be possible to cause a denial of service hitting the nofile limit as there is no possibility to configure or set a maximum number of connections.
Clone Of:
Environment:
Last Closed:
Embargoed:


Attachments (Terms of Use)

Description Patrick Del Bello 2024-05-02 12:25:37 UTC
A vulnerability was found in Wildlfly management interface where there is no sockets limits to perform connections to http management interface. This may lead occasionally to a Denial of Service (DoS) for Wildfly server after nofile limit reaches its maximum. This requires normally local access as the management interface is not exposed by default and it is not a common configuration to make it public.


Note You need to log in before you can comment on or make changes to this bug.