Bug 2280718 (CVE-2024-4853) - CVE-2024-4853 wireshark: Editcap byte chopping crash
Summary: CVE-2024-4853 wireshark: Editcap byte chopping crash
Keywords:
Status: NEW
Alias: CVE-2024-4853
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 2280719
Blocks: 2280710
TreeView+ depends on / blocked
 
Reported: 2024-05-15 22:10 UTC by Nick Tait
Modified: 2024-05-27 16:58 UTC (History)
0 users

Fixed In Version: wireshark 4.2.5, wireshark 4.0.15, wireshark 3.6.23
Doc Type: ---
Doc Text:
A flaw was found in the editcap program distributed by Wireshark. A buffer over-read may be triggered when a crafted packet trace file is processed with the editcap program, causing an application crash and resulting in a denial of service.
Clone Of:
Environment:
Last Closed:
Embargoed:


Attachments (Terms of Use)

Description Nick Tait 2024-05-15 22:10:16 UTC
Memory handling issue in editcap could cause denial of service via crafted capture file

https://gitlab.com/wireshark/wireshark/-/issues/19724
https://www.wireshark.org/security/wnpa-sec-2024-08.html

Comment 1 Nick Tait 2024-05-15 22:11:50 UTC
Created wireshark tracking bugs for this issue:

Affects: fedora-all [bug 2280719]


Note You need to log in before you can comment on or make changes to this bug.