Bug 2542700 (CVE-2026-102278) - CVE-2026-102278 brace-expansion: brace-expansion: Denial of Service via uncontrolled recursion in nested brace patterns
Summary: CVE-2026-102278 brace-expansion: brace-expansion: Denial of Service via uncon...
Keywords:
Status: NEW
Alias: CVE-2026-102278
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Product Security DevOps Team
QA Contact:
URL:
Whiteboard:
Depends On: 2550301 2550303 2550305 2550307 2550308 2550309 2550310 2550311 2550314 2550315 2550317 2550319 2550320 2550322 2550323 2550324 2550325 2550326 2550327 2550328 2550329 2550330 2550332 2550333 2550334 2550335 2550337 2550338 2552372 2550312 2550316 2550331 2550340 2550341
Blocks:
TreeView+ depends on / blocked
 
Reported: 2026-09-28 21:02 UTC by OSIDB Bzimport
Modified: 2026-10-29 22:29 UTC (History)
193 users (show)

Fixed In Version:
Clone Of:
Environment:
Last Closed:
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2026:92376 0 None None None 2026-10-29 14:20:44 UTC
Red Hat Product Errata RHSA-2026:92378 0 None None None 2026-10-29 22:29:24 UTC

Description OSIDB Bzimport 2026-09-28 21:02:26 UTC
The brace-expansion library generates arbitrary strings containing a common prefix and suffix. Prior to 1.1.20, 2.1.6, 3.0.8, and 5.0.11, deeply nested brace groups cause expand_() to recurse once per nesting level at comma-member and single-set expansion sites, exhausting the native stack before output limits can apply and potentially terminating the Node.js process. expand_ performs uncontrolled recursion for nested brace alternatives and single-part sets. deeply nested brace groups supplied as an untrusted pattern. expand_ is affected. expand is affected. Comma members is affected. Single set is affected. native stack exhaustion during nested sub-expansion. process-terminating denial of service. This issue is fixed in versions 1.1.20, 2.1.6, 3.0.8, and 5.0.11.

Comment 1 Jon Orris 2026-10-29 14:20:35 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 8

Via RHSA-2026:92376 https://access.redhat.com/errata/RHSA-2026:92376

Comment 2 Jon Orris 2026-10-29 22:29:13 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 9

Via RHSA-2026:92378 https://access.redhat.com/errata/RHSA-2026:92378


Note You need to log in before you can comment on or make changes to this bug.