Bug 490140 (zsync) - Review Request: zsync - Client-side implementation of the rsync algorithm
Summary: Review Request: zsync - Client-side implementation of the rsync algorithm
Alias: zsync
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
Target Milestone: ---
Assignee: Robert Scheck
QA Contact: Fedora Extras Quality Assurance
: 478617 533778 (view as bug list)
Depends On: 495310
Blocks: DuplicSysLibsTracker
TreeView+ depends on / blocked
Reported: 2009-03-13 14:33 UTC by Simon
Modified: 2020-04-24 14:32 UTC (History)
15 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2009-03-13 14:42:53 UTC
Type: ---
ppisar: fedora-review?

Attachments (Terms of Use)
zsync-0.6.1-nozlib.patch (2.39 KB, patch)
2009-10-14 01:42 UTC, Jens Petersen
no flags Details | Diff
patch to use zlib from forked from rsync (4.82 KB, patch)
2009-10-20 10:22 UTC, Dan Horák
no flags Details | Diff

Description Simon 2009-03-13 14:33:36 UTC
Spec URL:


Zsync is a file transfer program to download files from
remote web servers. If a previous version of a file is available
locally, zsync will only download changed parts and hereby
minimise the download volume. The algorithm is the same as used
by rsync, but zsync does not require any server software
(apart from a web server), nor does it need shell access.
Instead, it uses a control file (.zsync file) that describes the
file to be downloaded, which it uses to determine the blocks to
fetch. This file is created once on the server (and not for each
request) and sits next to actual file to download


Comment 1 Susi Lehtola 2009-03-13 14:42:53 UTC
A review request already exists for this package. Closing as duplicate.

*** This bug has been marked as a duplicate of bug 478617 ***

Comment 2 Robert Scheck 2009-04-10 22:06:31 UTC
https://fedorahosted.org/fesco/ticket/134 has to be solved/approved first.

Comment 3 Simon 2009-09-15 16:57:32 UTC
Update to 0.6.1

SPEC: http://cassmodiah.fedorapeople.org/zsync-0.6/zsync.spec
SRPM: http://cassmodiah.fedorapeople.org/zsync-0.6/zsync-0.6.1-1.fc11.src.rpm

Still the internal zlib problem!

Comment 4 Jens Petersen 2009-10-14 01:42:49 UTC
Created attachment 364673 [details]

Patching out the internal zlib and zsync still worksforme.

This patch could be improved with sufficient autofoo
to just just touch Makefile.am (and maybe also remove
zlib/Makefile.in from configure.ac, but I ran into
so nasty auto nonsense so stopped here.

Comment 5 Jens Petersen 2009-10-14 06:09:11 UTC
Comment on attachment 364673 [details]

Sorry I was not testing properly this doesn't build - got fooled by a hardlink moved by emacs... ;-(

Comment 6 Dan Horák 2009-10-20 10:22:35 UTC
Created attachment 365321 [details]
patch to use zlib from forked from rsync

the patch is not tested, just a proof-of-concept

Comment 7 Robert Scheck 2009-10-20 19:17:28 UTC
According to bug #495310 comment #15, that won't work.

Comment 8 Dan Horák 2009-11-09 08:07:59 UTC
*** Bug 533778 has been marked as a duplicate of this bug. ***

Comment 9 Thomas Spura 2010-04-02 17:54:25 UTC
*** Bug 478617 has been marked as a duplicate of this bug. ***

Comment 10 Thom Carlin 2011-02-22 18:09:32 UTC
Hey Robert, any updates on this bug?

Comment 11 Robert Scheck 2011-02-23 21:40:07 UTC
I'm not aware, that anything changed or improved so far...

Comment 12 Thom Carlin 2011-03-14 19:41:58 UTC
Any updates?

Comment 13 Christoph Wickert 2011-03-14 20:32:26 UTC
There is no use requesting info from Robert. If you read this bug carefully you will see that bug 504493 is blocking this one. If you want to advance there, please bring this up to FESCo or the Fedora packaging committee.

Comment 14 Michal Luscon 2013-02-08 13:37:25 UTC
Rsync upstream prepared patch, which allows to build rsync with system provided zlib. Are there any consequences of this patch regarding zsync?

commit 7da17144fd764a2420a8d08897475c0b7fdbf956

Comment 15 Kamil Páral 2013-02-08 13:51:45 UTC
I have found this in ./c/zlib/README.zsync in the zsync source code:

> Local changes to zlib used by zsync
> -----------------------------------
> ....
> Contrary to some internet discussion, the changes are not related to rsync's
> changes nor to rsync compatibility (zsync isn't compatible with rsync -
> whatever that would mean - nor do these changes relate in any way to the
> rsyncable gzip patch).

Do I understand it correctly that even if we unbudle zlib from rsync, it 1) won't have any impact on zsync 2) zsync will still not be fit to be included in Fedora?

Comment 16 Andre Robatino 2013-08-07 19:27:43 UTC
(In reply to Kamil Páral from comment #15)

> Do I understand it correctly that even if we unbudle zlib from rsync, it 1)
> won't have any impact on zsync 2) zsync will still not be fit to be included
> in Fedora?

I'd like to know too, since bug 495310 (rsync contains forked copy of zlib) was just closed in Rawhide.

Comment 17 Robert Scheck 2013-08-08 01:01:04 UTC
Interesting...I have the same understanding as in comment #15 but also the
same expectation as in comment #16. Might current rsync and zlib maintainers
maybe help us here porting zsync to use a system zlib? However this requires
a nice amount of expertise in that area, if I am not mistaken. Anyone?

Comment 18 Kamil Páral 2013-08-08 08:18:57 UTC
CCing Peter Schiffer, the current zlib maintainer.

Peter, would you be able to advise us here, please?

I have looked at OpenSUSE zsync package and IIUIC they use the upstream version, with bundled zlib. I'm not exactly clear on the rules for granting an exception in Fedora packaging guidelines, but we at least try to ask for it, if we don't find a better way.

Comment 19 Peter Schiffer 2013-08-08 09:31:47 UTC

I can try to look into this issue some time next week or so, but if I'm not mistaken, it was already asked for FESCO exception which was denied, here:


Comment 20 Upstream Release Monitoring 2015-09-24 15:04:27 UTC
jgrulich's scratch build of kdevelop?#c8e2b9bc57f11e41f3dc6612cdbcc591078d9062 for f22-candidate and git://pkgs.fedoraproject.org/kdevelop?#c8e2b9bc57f11e41f3dc6612cdbcc591078d9062 completed http://koji.fedoraproject.org/koji/taskinfo?taskID=11212117

Note You need to log in before you can comment on or make changes to this bug.