Bug 1439729

Summary: Swap partition is not created/used when using blivet-gui
Product: [Fedora] Fedora Reporter: Saurabh Thakre <mail.sau0>
Component: anacondaAssignee: Vojtech Trefny <vtrefny>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: urgent Docs Contact:
Priority: unspecified    
Version: 26CC: alciregi, anaconda-maint-list, bugzilla, g.kaviyarasu, jikortus, jonathan, jvavra, mkolman, vanmeeuwen+fedora, vponcova, vtrefny
Target Milestone: ---   
Target Release: ---   
Hardware: i586   
OS: Linux   
Whiteboard:
Fixed In Version: anaconda-26.21.3-1.fc26 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-04-13 14:08:12 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Saurabh Thakre 2017-04-06 12:35:21 UTC
Description of problem:
while doing LVM it seems to have many problems with lvm like on creating pv blivet-gui crashes.this time the swap partition is not created after booting and not shown in fstab also.


Version-Release number of selected component (if applicable):


How reproducible:anytime

Steps to Reproduce:
2. Use blivet-gui.
3. Create boot
4. Use LVM.
5.  root volume is added as lvm vg.
6.Add swap on same.
7. Finish installation.
Actual results:
no signs of creation of swap partition in fstab.

Expected results:
successfully creation of swap partition in the system.

Additional info:

Comment 1 Jiri Kortus 2017-04-06 12:52:19 UTC
I ran into a very similar issue even without LVM partitioning. The device for swap was created during installation, however it is not used in the installed system (not even mentioned in /etc/fstab).

Comment 2 Chris Murphy 2017-04-06 20:44:22 UTC
if GPT partitioning = true, and
if standard partition (not lvm) = true, and
if swap partition encrypted = false, and 
if swap partition type guid is 8200 (this is a gdisk value, the real guid is 0657FD6D-A4AB-43C4-84E5-0933C84B4F4F), then

It's OK to not list it in fstab, because systemd is supposed to discover it.

https://www.freedesktop.org/wiki/Specifications/DiscoverablePartitionsSpec/

Point is, the comment 1 bug could be a systemd bug and should be separately checked and have it's own bug report.

Comment 3 Alessio 2017-04-06 22:34:33 UTC
yup. The swap partition (using LVM or not) is actually created. But not activated on boot.
For instance swapon /dev/sda2 enable the swap partition.

journalctl |grep swap
Apr 07 00:26:54 localhost-live kernel: Adding 2097148k swap on /dev/sda2.  Priority:-1 extents:1 across:2097148k FS

systemctl |grep swap
dev-sda2.swap                                                                             loaded active active    /dev/sda2

Comment 4 Vojtech Trefny 2017-04-07 06:44:41 UTC
*** Bug 1439572 has been marked as a duplicate of this bug. ***

Comment 5 Vojtech Trefny 2017-04-07 07:58:31 UTC
Oops, forgot to tell Anaconda to configure new swaps created by blivet-gui. Thank you all for the testing.

https://github.com/rhinstaller/anaconda/pull/1017

Comment 6 Fedora Update System 2017-04-11 14:50:56 UTC
anaconda-26.21.3-1.fc26 blivet-gui-2.1.2-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-10db06fadf

Comment 7 Fedora Update System 2017-04-12 23:21:41 UTC
anaconda-26.21.3-1.fc26, blivet-gui-2.1.2-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-10db06fadf

Comment 8 Fedora Update System 2017-04-13 14:08:12 UTC
anaconda-26.21.3-1.fc26, blivet-gui-2.1.2-1.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2017-04-28 13:15:41 UTC
anaconda-26.21.4-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-f620d8c7c2

Comment 10 Saurabh Thakre 2017-04-30 17:35:27 UTC
Hello Fedora Update System I have verified the patch you have pushed to Fedora 26 stable repository  and the bug is solved.
Thanks for the update.