Bug 144366

Summary: Kernel 724_FC3 breaks MTIOCPOS ioctl
Product: [Fedora] Fedora Reporter: Robert Nichols <rnichols42>
Component: kernelAssignee: Dave Jones <davej>
Status: CLOSED ERRATA QA Contact: Brian Brock <bbrock>
Severity: medium Docs Contact:
Priority: medium    
Version: 3CC: pfrields, wtogami
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-01-12 07:24:27 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Robert Nichols 2005-01-06 15:28:19 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20041020

Description of problem:
Under this kernel, the MTIOCPOS ioctl to a scsi tape device fails,
returning ENODEV.  This was working in the 681_FC3 kernel.

Version-Release number of selected component (if applicable):
kernel-2.6.9-1.724_FC3

How reproducible:
Always

Steps to Reproduce:
1. On a system with a scsi tape device that supports the scsi READ
POSITION command, and with a tape loaded in the drive, run "mt tell".

    

Actual Results:  The command reports "/dev/tape: No such device" and
exits with a failure return.

Expected Results:  The command should print "At block nnnn." and
return success.

Additional info:

mt-st-0.8-1
Drive is:
  Host: scsi0 Channel: 00 Id: 04 Lun: 00
  Vendor: ARCHIVE  Model: Python 04106-XXX Rev: 7350
  Type:   Sequential-Access                ANSI SCSI revision: 02

Under kernel 2.6.9-1.681_FC3, "mt tell" works properly.  I can't use
'strace' or a debugger to verify what is happening because the 724_FC3
kernel also breaks process tracing (bug 144070).  I had to recompile
'mt' with some debugging printf()s to help identify the problem.

Comment 1 Robert Nichols 2005-01-12 07:11:13 UTC
"mt tell" is working properly again in kernel 2.6.10-1.737_FC3.