Bug 15566

Summary: HP OmniBook 6000 reboot hangs system
Product: [Retired] Red Hat Linux Reporter: Frank Sweetser <fs>
Component: kernelAssignee: Arjan van de Ven <arjanv>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: medium Docs Contact:
Priority: high    
Version: 7.1   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard: Winston gold
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2004-09-30 15:38:48 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Frank Sweetser 2000-08-06 15:45:13 UTC
Try to do a shutdown -r now.  It goes through all of the init scripts, but when it tries to actually reset the machine, it just ends up locking the 
system up rock hard - pop-the-battery required.  shutdown -h now works perfectly, though, including powering the system off.

Comment 1 Glen Foster 2000-08-07 17:39:01 UTC
This defect is considered MUST-FIX for Winston Gold-release

Comment 2 Frank Sweetser 2000-08-07 18:56:06 UTC
Appears to work under 2.2.17pre15 with same .config as stock RH kernel, minus
CONFIG_FB_ATY.

Comment 3 Michael K. Johnson 2000-08-17 20:27:47 UTC
BTW, pop-the-battery should not be required -- have you tried
holding down the power button for 4 seconds?

Comment 4 Michael K. Johnson 2000-08-17 20:33:19 UTC
CONFIG_FB_ATY=m; are you loading the module?

Comment 5 Frank Sweetser 2000-08-17 20:52:34 UTC
No, the power for several seconds doesn't seem to work, though now that I've
found it the magic keyhole in the side does =)

And no, doesn't look like the the related module is loaded - with the default
kernel I've got ds, i82365, pcmcia_core, lockd, sunrpc, 3c59x, agpgart,
usb-uhci, and usbcore loaded.

Comment 6 Michael K. Johnson 2000-08-17 21:04:29 UTC
So 2.2.17pre15 with CONFIG_FB_ATY=m still has the problem?

Comment 7 Frank Sweetser 2000-08-17 21:08:06 UTC
Sorry, should have been clearer - the 2.2.17pre's defaulted to CONFIG_FB_ATY=y. 
With this set, I couldn't even get a console at all.  So, I disabled it, and
found that I could reboot under the 17pre kernels fine.  I haven't tried with =m
yet as I assumed it wouldn't make a difference, but I could if you'd like.

Comment 8 Bill Nottingham 2000-08-18 15:28:41 UTC
Does (with the rc1 kernel) booting with:

linux init=/bin/bash

and then running

/sbin/reboot -f

work?

Comment 9 Frank Sweetser 2000-08-18 15:50:21 UTC
Yes, that reboots it fine.

Comment 10 Michael K. Johnson 2000-08-21 19:53:15 UTC
OK, I don't think that CONFIG_ATY_FB actually has anything
to do with the problem, probably a red herring.

Does it change anything if you chkconfig apmd off?

Comment 11 Frank Sweetser 2000-08-21 20:10:06 UTC
Nope, still hangs.

Comment 12 Frank Sweetser 2001-01-09 21:17:10 UTC
Still present in 7.1 beta 2.

Comment 13 Frank Sweetser 2001-01-31 19:43:42 UTC
7.1 beta 3.  Tried with reboot=warm, cold, bios, and hard, same results - hard
lockup.

Comment 14 Michael K. Johnson 2001-02-08 17:58:47 UTC
How about apm=no -- does that change it?

Comment 15 Frank Sweetser 2001-02-08 18:30:10 UTC
Nope - with apm=off ACPI fails to load, and it still locks up on reboot.  Also
tried with apm=off, no pcmcia, no apmd, same result.

Comment 16 Bugzilla owner 2004-09-30 15:38:48 UTC
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem
persists.

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/