Bug 28281

Summary: Windows 98 can't read disk after Fisher was installed
Product: [Retired] Red Hat Linux Reporter: Need Real Name <thhoye>
Component: anacondaAssignee: Michael Fulbright <msf>
Status: CLOSED NOTABUG QA Contact: Aaron Brown <abrown>
Severity: high Docs Contact:
Priority: medium    
Version: 7.1CC: wayfarer-rhb
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2001-03-08 07:23:14 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Need Real Name 2001-02-19 12:03:26 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)

After I installed Fisher, and mounted a (separate) disk with a FAT32 
partition, I am unable to read the disk when I boot to DOS/Windows 98.

Reproducible: Couldn't Reproduce
Steps to Reproduce:

I installed Fisher using the feature that finds old Linux partitions and 
uses them. The disk that is messed up should not be touched by this. It is 
a 8GB disk, formatted in one partition as FAT32. After Fisher was 
installed, I mounted it, and perhaps executed ls on it, but didn't write 
anything. When I rebooted to Windows 98 the first time, it tried to run 
SCANDISK on it, but it crashed totally, before it was able to start 
checking it. I was unable to start Windows until I physically disconnected 
the bad disk. When I boot to DOS and run DIR on it, the screen is filled 
with mainly grabage, and a few entries that look like files with bad 
names, but nothing of the original, and in the end it says there is a 
partition error. Norton Disk Doctor was also unable to read it, and did 
not want to try to fix it. I can still mount and read it in Fisher, 
though, and I was able to copy out all the important files. When I try to 
run the fsck for DOS, it does not find any errors. I mounted another 45GB 
FAT32 disk without any problems, and I have also copied both to and from 
it. I use a HPT370 controller. Linux was installed on the first disk on 
the first port, the messed up disk is the second disk on the first port, 
and the 45 GB disk is alone on the second port. If there is a program I 
can run to get a copy of the partition table or anything else that might 
help you, please let me know.

Comment 1 Michael Fulbright 2001-02-28 15:20:08 UTC
How was your system partitioned before installing Fisher?

How do your partitions look now (you can use the fdisk -l /dev/hda, for example,
to get the partitions on /dev/hda)?

Comment 2 Need Real Name 2001-02-28 22:26:53 UTC
fdisk -l info for all my disks. hdf is the one that doesn't work in DOS. I have
been tipped by a person who thinks he may have had the same problem, that fdisk
/mbr might fix it. I have not tried it yet, as I wanted to be able to give you
the info you need. Unless I hear from you again in a few days, I'll try it, and
let you know what happens.I have not changed the layout of the disks after I
installed Redhat.

Disk /dev/hde: 255 heads, 63 sectors, 1229 cylinders
Units = cylinders of 16065 * 512 bytes

   Device Boot    Start       End    Blocks   Id  System
/dev/hde1   *         1       396   3180838+   b  Win95 FAT32
/dev/hde2           397       399     24097+  83  Linux
/dev/hde3           400      1229   6666975    5  Extended
/dev/hde5           400      1220   6594651   83  Linux
/dev/hde6          1221      1229     72261   82  Linux swap

Disk /dev/hdf: 255 heads, 63 sectors, 1046 cylinders
Units = cylinders of 16065 * 512 bytes

   Device Boot    Start       End    Blocks   Id  System
/dev/hdf1   *         2      1046   8393962+   f  Win95 Ext'd (LBA)
/dev/hdf5             2      1046   8393931    b  Win95 FAT32

Disk /dev/hdg: 255 heads, 63 sectors, 5473 cylinders
Units = cylinders of 16065 * 512 bytes

   Device Boot    Start       End    Blocks   Id  System
/dev/hdg1   *         1      5473  43961841    c  Win95 FAT32 (LBA)

Comment 3 Michael Fulbright 2001-03-02 16:45:14 UTC
Have you tried the newer wolverine beta?

Comment 4 Need Real Name 2001-03-02 17:24:59 UTC
No, should that fix the disk, or just crash it again? I haven't fixed it yet.

Comment 5 Need Real Name 2001-03-08 07:23:06 UTC
Just FYI, I've had the same problem with Fisher and Win98.  The partition setup
I ended up with is as follows:

Disk /dev/hda: 255 heads, 63 sectors, 1027 cylinders
Units = cylinders of 16065 * 512 bytes

   Device Boot    Start       End    Blocks   Id  System
/dev/hda1   *         1        16    128488+   6  FAT16
/dev/hda2            17        19     24097+  83  Linux
/dev/hda3           325      1027   5646847+   c  Win95 FAT32 (LBA)
/dev/hda4            20       324   2449912+   5  Extended
/dev/hda5            20       315   2377588+  83  Linux
/dev/hda6           316       324     72261   82  Linux swap

Yes, the partitions were originally out of disk order.  

Unfortunately, I didn't have the foresight to make a list of the original
partition boundaries.  Although Windows (off /dev/hda1 or a boot floppy)
apparently has problems with the file allocation table on /dev/hda3 (namely, the
directory listing looks like the Matrix), Linux reads it just fine.

I haven't been able to reproduce this bug--for lack of trying.  When I do the
ol' Windows format/reinstall on /dev/hda3, I'll try installing Wolverine, just
to see if the bug persists in the newest beta.  However, I have a feeling that
the gremlin that popped up in the Fisher install has done its job and gone home
for a nice cuppa tea.

Comment 6 Michael Fulbright 2001-03-20 19:32:57 UTC
Partitioning seems to causes lots of problems on certain systems, I am sorry you
encountered these issues.

I am not sure what we can do at this point to help.  I will close the bug as
NOTABUG (closest match to the situation we have) but please reopen if you have
new problems or information.

Comment 7 Elliot Lee 2001-07-18 19:42:28 UTC
*** Bug 45885 has been marked as a duplicate of this bug. ***