Bug 45885 - linux installer hoses hard disk for windows 2k
linux installer hoses hard disk for windows 2k
Status: CLOSED DUPLICATE of bug 28281
Product: Red Hat Linux
Classification: Retired
Component: util-linux (Show other bugs)
7.1
i686 Linux
high Severity high
: ---
: ---
Assigned To: Elliot Lee
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-25 15:30 EDT by Gerald Koh
Modified: 2005-10-31 17:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-16 09:33:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gerald Koh 2001-06-25 15:30:41 EDT
i couldn't find a component for this problem, so i picked mtools, since 
that has something to do with the sort of problem.  please forward to 
appropriate person:

Description of Problem:

The installer (the part where it formats the filesystem and copys the 
files) popped up an error either with the partitioning or the disk 
geometry. It rebooted, 'fixed' the problem, and installed fine.  but now 
the windows installer can't read the drive, reporting:

error 00008001: unable to arcread boot partition for signature.

dos fdisk /mbr reports: Master Boot Code NOT Updated.

partition magic won't even load, and reports 'unable to access master boot 
record'

I low level formatted the drive and used mbrtool (from diydatarecovery) to 
wipe the entire track 0.  I also used it to put down the standard wintel 
boot code and signature bytes (using mbrtool, since dos fdisk won't work).

All I want to do is put win2k back (since i have a dedicated linux box now)

How Reproducible:

probably not very, since this sounds similar to bug #28281. I have an abit 
kt7 mb with a 1 ghz athlon thunderbird.  everything runs off an adaptec 
29160 controller. The drive is an IBM DDYS 18 GB SCSI /160 drive.  There 
is also a pioneer DVD drive, a plextor 40x reader and a plextor 12x 
writer.  There may be existing SCSI bugs, because the hard drive would 
never boot if support for bootable cdroms was enabled in the SCSI BIOS. 
But i did have w2k installed successfully.  Here's what i did:

Steps to Reproduce:
1. start with 1 w2k partition.
2. used partition magic to make a data partition, w2k partition, and empty 
space for linux.
3. installed linux, got a warning about partitions in the wrong order, and 
then the above error message.
4. rebooted, linux installed fine, then no dos / win programs could read 
the mbr.
5. low level formatted the drive, wiped track 0, windows still can't see 
the drive.

Actual Results:


Expected Results:


Additional Information:
	
I suspect that the problem is that the linux partitioner (i used fdisk) is 
capable of affecting more of the drive than the dos fdisk.  i would like 
to know exactly what linux fdisk can do that dos fdisk can't. i suspect it 
changed the drive geometry, and i'll mess with that tonight.
Comment 1 Johnray Fuller 2001-06-25 15:54:55 EDT
I moved the bug to util-linux since he used fdisk
Comment 2 Bernhard Rosenkraenzer 2001-06-26 07:29:13 EDT
Assigning to util-linux owner; doesn't seem to be reproducable though. (Yes, 
it's probably a duplicate of #28281)
Comment 3 Elliot Lee 2001-07-18 15:42:33 EDT

*** This bug has been marked as a duplicate of 28281 ***

Note You need to log in before you can comment on or make changes to this bug.