Bug 432433

Summary: changes meaning of 'special_values_parser'
Product: [Fedora] Fedora Reporter: Patrice Dumas <pertusus>
Component: boostAssignee: Benjamin Kosnik <bkoz>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: low    
Version: rawhideCC: drago01, mnewsome, pmachata
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-02-13 17:03:35 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Patrice Dumas 2008-02-12 00:15:24 UTC
Description of problem:

When compiling gnash, I get:

In file included from /usr/include/boost/date_time/gregorian/gregorian_io.hpp:13,
                 from /usr/include/boost/date_time/gregorian/conversion.hpp:24,
                 from /usr/include/boost/date_time/gregorian/gregorian.hpp:22,
                 from
/usr/include/boost/date_time/posix_time/time_formatters.hpp:13,
                 from /usr/include/boost/date_time/posix_time/posix_time.hpp:25,
                 from ../libamf/element.h:32,
                 from ../libamf/amf.h:31,
                 from FLVParser.cpp:24:
/usr/include/boost/date_time/date_facet.hpp:560: error: declaration of 'void
boost::date_time::date_input_facet<date_type, CharT,
InItrT>::special_values_parser(boost::date_time::special_values_parser<date_type, charT>)'
/usr/include/boost/date_time/special_values_parser.hpp:34: error: changes
meaning of 'special_values_parser' from 'class
boost::date_time::special_values_parser<date_type, charT>'
make[2]: *** [libgnashbase_la-FLVParser.lo] Erreur 1

Looks like a boost bug to me, showing up with gcc 4.3.0.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Petr Machata 2008-02-13 13:07:52 UTC
*** Bug 432611 has been marked as a duplicate of this bug. ***

Comment 2 Petr Machata 2008-02-13 15:21:46 UTC
I fixed what seems to be the culprit, new boost build is spinning:
http://koji.fedoraproject.org/koji/taskinfo?taskID=423476

But actually I was unable to reproduce your problem with gnash build.  There was
another GCC 4.3 related problem, which was trivially fixed with #include
<string.h>, and I had to BR kdelibs3; but other than that, the build passed:
http://koji.fedoraproject.org/koji/taskinfo?taskID=423304

Comment 3 Patrice Dumas 2008-02-13 15:29:40 UTC
Sorry, I should have said that it is the cvs of gnash
(which should be released soon).

Comment 4 Petr Machata 2008-02-13 17:03:35 UTC
I tried the CVS gnash, and the build passed with freshly built boost package. 
So this is fixed as far as I can tell.

(drago01@gmail.com): If the problem doesn't go away for you, feel free to reopen
the bug.