Bug 432611 - boost headers need to be fixed for gcc-4.3
Summary: boost headers need to be fixed for gcc-4.3
Status: CLOSED DUPLICATE of bug 432433
Alias: None
Product: Fedora
Classification: Fedora
Component: boost   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Benjamin Kosnik
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-02-13 11:37 UTC by drago01
Modified: 2013-08-09 05:48 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-13 13:07:51 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description drago01 2008-02-13 11:37:07 UTC
Description of problem:

Some packages in rawhide fails to build against boost with gcc-4.3.
The error message is:
-------------------------
/usr/include/boost/date_time/date_facet.hpp:560: error: declaration of 'void
boost::date_time::date_input_facet<date_type, CharT,
InItrT>::special_values_parser(boost::date_time::special_values_parser<date_type,
charT>)'
/usr/include/boost/date_time/special_values_parser.hpp:34: error: changes
meaning of 'special_values_parser' from 'class
boost::date_time::special_values_parser<date_type, charT>'
--------------------------
This seems not to affect boost itself but packages that include this header.

Comment 1 Petr Machata 2008-02-13 13:07:51 UTC

*** This bug has been marked as a duplicate of 432433 ***


Note You need to log in before you can comment on or make changes to this bug.