Bug 43362

Summary: seemingly excessive requirements in a spec file
Product: [Retired] Red Hat Raw Hide Reporter: Michal Jaegermann <michal>
Component: XFree86Assignee: Mike A. Harris <mharris>
Status: CLOSED RAWHIDE QA Contact: David Lawrence <dkl>
Severity: medium Docs Contact:
Priority: low    
Version: 1.0CC: notting
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2001-06-11 15:04:21 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Michal Jaegermann 2001-06-03 22:57:25 UTC
Description of Problem:

Spec files for XFree86-4.0.3 (various versions) have in requirements
initscripts at least 5.20.  Why so high?  I recompiled these sources
a number of times for a system with initscripts-5.00 and I do not see
any ill-effects.

Comment 1 Mike A. Harris 2001-06-04 08:43:58 UTC
I do not recall why the dependancy is on 5.20, nor do I recall if I set
it to that, or if I inherited XFree86 with it like that.  The changelogs
do not seem to contain any comments as to why it was changed.  My guess
is that the new xfs initscript is i18nized, and that it requires updated
initscripts for this to work?  I dunno for sure, but I assume that whoever
set it to require initscripts 5.20 or greater had good reason even if they
did not document it.  As such, I'm inclined to leave it as is rather than
remove it just to find out why.

Bill, do you know what reason we're requiring 5.20 or greater?

Comment 2 Bill Nottingham 2001-06-11 15:04:17 UTC
It was for the old i18n that we ended up not using. Feel free to axe it.

Comment 3 Mike A. Harris 2001-06-12 02:43:32 UTC
Ok, will do in 4.1.0, but I'm not going to touch 4.0.3 as I don't
want to create any surprises in a stable series.

Thanks.  Fixed in 4.1.0-0.6.0