Bug 43362 - seemingly excessive requirements in a spec file
Summary: seemingly excessive requirements in a spec file
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: XFree86
Version: 1.0
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-06-03 22:57 UTC by Michal Jaegermann
Modified: 2007-03-27 03:45 UTC (History)
1 user (show)

(edit)
Clone Of:
(edit)
Last Closed: 2001-06-11 15:04:21 UTC


Attachments (Terms of Use)

Description Michal Jaegermann 2001-06-03 22:57:25 UTC
Description of Problem:

Spec files for XFree86-4.0.3 (various versions) have in requirements
initscripts at least 5.20.  Why so high?  I recompiled these sources
a number of times for a system with initscripts-5.00 and I do not see
any ill-effects.

Comment 1 Mike A. Harris 2001-06-04 08:43:58 UTC
I do not recall why the dependancy is on 5.20, nor do I recall if I set
it to that, or if I inherited XFree86 with it like that.  The changelogs
do not seem to contain any comments as to why it was changed.  My guess
is that the new xfs initscript is i18nized, and that it requires updated
initscripts for this to work?  I dunno for sure, but I assume that whoever
set it to require initscripts 5.20 or greater had good reason even if they
did not document it.  As such, I'm inclined to leave it as is rather than
remove it just to find out why.

Bill, do you know what reason we're requiring 5.20 or greater?

Comment 2 Bill Nottingham 2001-06-11 15:04:17 UTC
It was for the old i18n that we ended up not using. Feel free to axe it.

Comment 3 Mike A. Harris 2001-06-12 02:43:32 UTC
Ok, will do in 4.1.0, but I'm not going to touch 4.0.3 as I don't
want to create any surprises in a stable series.

Thanks.  Fixed in 4.1.0-0.6.0


Note You need to log in before you can comment on or make changes to this bug.