Bug 46792

Summary: python traceback error during video card probe
Product: [Retired] Red Hat Linux Reporter: Chris Runge <crunge>
Component: anacondaAssignee: Michael Fulbright <msf>
Status: CLOSED RAWHIDE QA Contact: Brock Organ <borgan>
Severity: high Docs Contact:
Priority: high    
Version: 7.3CC: agrajag
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2001-07-17 12:06:19 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Chris Runge 2001-06-30 17:07:05 UTC
Description of Problem:

Fairfax (beta 1)

when I do a graphical or text mode NFS install, after it connects to the 
NFS server I get this error:

Running anaconda - please wait...
Probing for video card:   Traceback (innermost last):
  File "/usr/bin/anaconda", line 358, in ?
    videohw    = videocard.VideoCardInfo()
  File "/usr/lib/anaconda/videocard.py", line 288, in __init__
    If info:
NameError: info
install existed abnormally
sending termination signals...done
sending kill signals...done
disabling swap...
unmounting filesystems...
        /mnt/runtime done
        disabling /dev/loop0
        /proc/bus/usb done
        /proc done
        /dev/pts done
        /mnt/source umount failed (16)
you may safely reboot your system

How Reproducible:

every time

Steps to Reproduce:
1. insert bootnet.img floppy
2. specify text or graphical install (only options tried so far)
3. specify nfs server; after downloading the aic7xxx scsi driver the 
problem occurs

Actual Results:

see above

Expected Results:

normal install

Additional Information:
I didn't have this problem on another machine, which uses a Voodoo 3 2000 
PCI video card. The machine I had the problem on has a GeForce 3 card. I'm 
guessing that is the problem. I am able to install 7.1 on the GeForce 3-
based machine, although the card isn't recognized (the PCI ID information 
isn't in the kernel sources or in Xconfigurator).

Marking as high priority/severity since I am unable to install/test on the 
GeForce 3 box.

Comment 1 Sean Dilda 2001-06-30 21:25:31 UTC
I duplicated this traceback when trying to do an ftp install onto vmware version

Comment 2 James Riggs 2001-07-02 14:33:20 UTC
I am also able to duplicate this error when running a CD rom install using a
FireGL4 graphics card.
Graphical setup and text setup both fail.

Comment 3 Michael Fulbright 2001-07-02 15:27:17 UTC
Just for the record - does 7.1 probe these cards correctly?

Comment 4 Chris Runge 2001-07-02 18:15:10 UTC
Red Hat Linux 7.1 installs fine on the GeForce 3-based system, although it
doesn't detect the GeForce 3 card.

I am increasingly convinced the GeForce 3 card is the issue (not the hardware
itself, but the inability of the installer to handle it) since the install gets
past this stage on another PC with another (Voodoo 3) video card.

Comment 5 Michael Fulbright 2001-07-10 15:37:54 UTC
I've done something to avoid the immediate traceback, but I need to test with a
card which is not in our db.

Comment 6 Michael Fulbright 2001-07-11 19:39:34 UTC
Going to address video issues post beta 2

Comment 7 Glen Foster 2001-07-13 19:45:00 UTC
This defect considered MUST-FIX for Fairfax gold-release.

Comment 8 Chris Runge 2001-07-17 12:05:22 UTC
update using beta 2...

I am still unable to install in either graphical mode or text mode. The card now
seems to be somewhat recognized but I still get a traceback (albeit a different
one) at the same point in the installation routine...

Running anaconda - please wait...
Probing for video card:   Traceback (innermost last):
  File "/usr/bin/anaconda", line 363, in ?
    videohw    = videocard.VideoCardInfo()
  File "/usr/lib/anaconda/videocard.py", line 285, in __init__
    info = Video_cardslist [server[5:]]
KeyError: NVIDIA GeForce 3 (generic)
install exited abnormally
sending termination signals...done
sending kill signals...done

Comment 9 Michael Fulbright 2001-07-18 20:39:18 UTC
Fixed for beta 3.