Bug 46792 - python traceback error during video card probe
python traceback error during video card probe
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
i386 Linux
high Severity high
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-30 13:07 EDT by Chris Runge
Modified: 2005-10-31 17:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-17 08:06:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Runge 2001-06-30 13:07:05 EDT
Description of Problem:

Fairfax (beta 1)

when I do a graphical or text mode NFS install, after it connects to the 
NFS server I get this error:

Running anaconda - please wait...
Probing for video card:   Traceback (innermost last):
  File "/usr/bin/anaconda", line 358, in ?
    videohw    = videocard.VideoCardInfo()
  File "/usr/lib/anaconda/videocard.py", line 288, in __init__
    If info:
NameError: info
install existed abnormally
sending termination signals...done
sending kill signals...done
disabling swap...
unmounting filesystems...
        /mnt/runtime done
        disabling /dev/loop0
        /proc/bus/usb done
        /proc done
        /dev/pts done
        /mnt/source umount failed (16)
you may safely reboot your system


How Reproducible:

every time

Steps to Reproduce:
1. insert bootnet.img floppy
2. specify text or graphical install (only options tried so far)
3. specify nfs server; after downloading the aic7xxx scsi driver the 
problem occurs

Actual Results:

see above

Expected Results:

normal install

Additional Information:
	
I didn't have this problem on another machine, which uses a Voodoo 3 2000 
PCI video card. The machine I had the problem on has a GeForce 3 card. I'm 
guessing that is the problem. I am able to install 7.1 on the GeForce 3-
based machine, although the card isn't recognized (the PCI ID information 
isn't in the kernel sources or in Xconfigurator).

Marking as high priority/severity since I am unable to install/test on the 
GeForce 3 box.
Comment 1 Sean Dilda 2001-06-30 17:25:31 EDT
I duplicated this traceback when trying to do an ftp install onto vmware version
2.0.4
Comment 2 James Riggs 2001-07-02 10:33:20 EDT
I am also able to duplicate this error when running a CD rom install using a
FireGL4 graphics card.
Graphical setup and text setup both fail.
Comment 3 Michael Fulbright 2001-07-02 11:27:17 EDT
Just for the record - does 7.1 probe these cards correctly?
Comment 4 Chris Runge 2001-07-02 14:15:10 EDT
Red Hat Linux 7.1 installs fine on the GeForce 3-based system, although it
doesn't detect the GeForce 3 card.

I am increasingly convinced the GeForce 3 card is the issue (not the hardware
itself, but the inability of the installer to handle it) since the install gets
past this stage on another PC with another (Voodoo 3) video card.
Comment 5 Michael Fulbright 2001-07-10 11:37:54 EDT
I've done something to avoid the immediate traceback, but I need to test with a
card which is not in our db.
Comment 6 Michael Fulbright 2001-07-11 15:39:34 EDT
Going to address video issues post beta 2
Comment 7 Glen Foster 2001-07-13 15:45:00 EDT
This defect considered MUST-FIX for Fairfax gold-release.
Comment 8 Chris Runge 2001-07-17 08:05:22 EDT
update using beta 2...

I am still unable to install in either graphical mode or text mode. The card now
seems to be somewhat recognized but I still get a traceback (albeit a different
one) at the same point in the installation routine...

Running anaconda - please wait...
Probing for video card:   Traceback (innermost last):
  File "/usr/bin/anaconda", line 363, in ?
    videohw    = videocard.VideoCardInfo()
  File "/usr/lib/anaconda/videocard.py", line 285, in __init__
    info = Video_cardslist [server[5:]]
KeyError: NVIDIA GeForce 3 (generic)
install exited abnormally
sending termination signals...done
sending kill signals...done
.
.
.
Comment 9 Michael Fulbright 2001-07-18 16:39:18 EDT
Fixed for beta 3.

Note You need to log in before you can comment on or make changes to this bug.