Bug 51765

Summary: floppy access causes panic with bad media
Product: [Retired] Red Hat Linux Reporter: Anthon Pang <apang>
Component: kernelAssignee: Arjan van de Ven <arjanv>
Status: CLOSED CURRENTRELEASE QA Contact: David Lawrence <dkl>
Severity: medium Docs Contact:
Priority: medium    
Version: 7.1   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-06-06 17:00:03 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Anthon Pang 2001-08-14 21:09:20 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 4.01; Windows NT)

Description of problem:
During the bootnet install and later using 'mkbootdisk' manually, the 
system hangs (motherboard/BIOS specific symptoms: power LED flashes, high 
pitched beeeeeeep, floppy LED lit solid, no response to keyboard, etc).

Version-Release number of selected component (if applicable):
	mkbootdisk: 1.4.2
	kernel: 2.4.2-2

How reproducible:
Always

Steps to Reproduce:
1. mkbootdisk 2.4.2-2

(Reproduceable everytime inasmuch as this was only attempted twice - once 
during the install, and once post-install.)

Actual Results:  Reboot!

Grabbed a second floppy, and mkbootdisk worked flawlessly, so I don't 
suspect the floppy drive itself.

Ran 'mkbadblocks' and 'chkdsk /r' (from NT4) to verify the first floppy 
disk's integrity.  No errors reported, but the latter might have silently 
fixed the disk.

Re-ran mkbootdisk on the first floppy, and it worked.  *sigh*  It's now no 
longer reproduceable.

Suspect marginal quality media (albeit "name brand").

Expected Results:  Should have recovered more gracefully, the first couple 
of times.

Additional info:

Error messages:
	None

Hardware:
	CPU: Athlon TB 1 GHz
	Mem: 1 Gb SDRAM
	M/B: Asus A7A266

Comment 1 Anthon Pang 2002-10-07 21:55:31 UTC
Sorry, I forgot to re-test this specifically from the shell with
mkbootdisk-1.4.8-1 before permanently discarding the bad media.  However, the
RH8 GUI install did recover, detecting a problem while creating the boot disk on
the aforementioned bad media.  If the GUI install uses mkbootdisk, then this bug
can be closed.