Bug 51765 - floppy access causes panic with bad media
floppy access causes panic with bad media
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-14 17:09 EDT by Anthon Pang
Modified: 2007-04-18 12:35 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-06 13:00:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anthon Pang 2001-08-14 17:09:20 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 4.01; Windows NT)

Description of problem:
During the bootnet install and later using 'mkbootdisk' manually, the 
system hangs (motherboard/BIOS specific symptoms: power LED flashes, high 
pitched beeeeeeep, floppy LED lit solid, no response to keyboard, etc).

Version-Release number of selected component (if applicable):
	mkbootdisk: 1.4.2
	kernel: 2.4.2-2

How reproducible:
Always

Steps to Reproduce:
1. mkbootdisk 2.4.2-2

(Reproduceable everytime inasmuch as this was only attempted twice - once 
during the install, and once post-install.)

Actual Results:  Reboot!

Grabbed a second floppy, and mkbootdisk worked flawlessly, so I don't 
suspect the floppy drive itself.

Ran 'mkbadblocks' and 'chkdsk /r' (from NT4) to verify the first floppy 
disk's integrity.  No errors reported, but the latter might have silently 
fixed the disk.

Re-ran mkbootdisk on the first floppy, and it worked.  *sigh*  It's now no 
longer reproduceable.

Suspect marginal quality media (albeit "name brand").

Expected Results:  Should have recovered more gracefully, the first couple 
of times.

Additional info:

Error messages:
	None

Hardware:
	CPU: Athlon TB 1 GHz
	Mem: 1 Gb SDRAM
	M/B: Asus A7A266
Comment 1 Anthon Pang 2002-10-07 17:55:31 EDT
Sorry, I forgot to re-test this specifically from the shell with
mkbootdisk-1.4.8-1 before permanently discarding the bad media.  However, the
RH8 GUI install did recover, detecting a problem while creating the boot disk on
the aforementioned bad media.  If the GUI install uses mkbootdisk, then this bug
can be closed.

Note You need to log in before you can comment on or make changes to this bug.