Bug 9490

Summary: autofs ceased to work after upgrade
Product: [Retired] Red Hat Linux Reporter: Tomasz Kepczynski <tomek>
Component: autofsAssignee: Cristian Gafton <gafton>
Status: CLOSED RAWHIDE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6.2   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2000-02-29 13:42:33 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Tomasz Kepczynski 2000-02-16 19:50:40 UTC
autofs stopped working after upgrade 6.1 -> 6.1.92. May be related to
timeout option as syslogs showed:
Feb 15 21:09:05 geralt kernel: EXT2-fs: Unrecognized mount option 60
and timeout in auto.master was 60 seconds.
May be related to 9489 as this happend on the same system.
This happens on smp kernel as shipped and on 2.2.14 I use currently (no
sun disklabel in the latter).

Comment 1 Tomasz Kepczynski 2000-02-24 15:10:59 UTC
This is wild quess but I think the problem is related to
autofs-3.1.4-loop.patch patch.

Comment 2 Nalin Dahyabhai 2000-02-28 22:49:59 UTC
*** Bug 9673 has been marked as a duplicate of this bug. ***

Comment 3 Nalin Dahyabhai 2000-02-29 13:42:59 UTC
The autofs init script gets changed with every release, and 3.1.4 is no
exception.  This appears to be a bug related to the parsing of parameters
in the master automounter map.

It should be fixed in 3.1.4-4.  If it does not solve the problem, please reopen
this bug ID and append a copy of the automounter map you're using so that I can
take a closer look at it.