Bug 1008633

Summary: ValueError: invalid target size request
Product: [Fedora] Fedora Reporter: Reartes Guillermo <rtguille>
Component: anacondaAssignee: David Lehman <dlehman>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 20CC: anaconda-maint-list, awilliam, bugzilla, dshea, g.kaviyarasu, jonathan, kparal, mkolman, mkrizek, mruckman, robatino, satellitgo, sbueno, vanmeeuwen+fedora, vpodzime
Target Milestone: ---Keywords: Reopened
Target Release: ---   
Hardware: x86_64   
OS: Unspecified   
Whiteboard: abrt_hash:d76ba3d76d15e4347e173ef4cdd96a465e65dafbf558520e7fa9916a643cc3d2 RejectedBlocker
Fixed In Version: anaconda-20.25.4-1 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-11-12 19:25:09 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
File: anaconda-tb
none
File: anaconda.log
none
File: environ
none
File: lsblk_output
none
File: nmcli_dev_list
none
File: os_info
none
File: program.log
none
File: storage.log
none
File: syslog
none
File: ifcfg.log
none
File: packaging.log
none
anaconda-tb-bHr5cn none

Description Reartes Guillermo 2013-09-16 13:43:36 EDT
Description of problem:
Guest has W7 default install.

I tried to resize the big ntfs partition in custom partitioning.
I changed the size and then clicked 'update parameters'. 
Anaconda crashed immediately.

Version-Release number of selected component:
anaconda-20.15-1

The following was filed automatically by anaconda:
anaconda 20.15-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/blivet/formats/fs.py", line 207, in _setTargetSize
    raise ValueError("invalid target size request")
  File "/usr/lib/python2.7/site-packages/blivet/deviceaction.py", line 589, in __init__
    self.device.format.targetSize = newsize
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 1247, in resizeDevice
    self.devicetree.registerAction(action_class(device, new_size))
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 1441, in _save_right_side
    self.__storage.resizeDevice(device, size)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 2788, in on_apply_clicked
    self._save_right_side(self._current_selector)
ValueError: invalid target size request

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2020-Alpha\x20x86_64 quiet BOOT_IMAGE=vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.11.0-300.fc20.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        20-Alpha

Potential duplicate: bug 986575
Comment 1 Reartes Guillermo 2013-09-16 13:43:49 EDT
Created attachment 798369 [details]
File: anaconda-tb
Comment 2 Reartes Guillermo 2013-09-16 13:43:54 EDT
Created attachment 798370 [details]
File: anaconda.log
Comment 3 Reartes Guillermo 2013-09-16 13:43:59 EDT
Created attachment 798371 [details]
File: environ
Comment 4 Reartes Guillermo 2013-09-16 13:44:03 EDT
Created attachment 798372 [details]
File: lsblk_output
Comment 5 Reartes Guillermo 2013-09-16 13:44:08 EDT
Created attachment 798373 [details]
File: nmcli_dev_list
Comment 6 Reartes Guillermo 2013-09-16 13:44:14 EDT
Created attachment 798374 [details]
File: os_info
Comment 7 Reartes Guillermo 2013-09-16 13:44:21 EDT
Created attachment 798375 [details]
File: program.log
Comment 8 Reartes Guillermo 2013-09-16 13:44:26 EDT
Created attachment 798376 [details]
File: storage.log
Comment 9 Reartes Guillermo 2013-09-16 13:44:32 EDT
Created attachment 798377 [details]
File: syslog
Comment 10 Reartes Guillermo 2013-09-16 13:44:36 EDT
Created attachment 798378 [details]
File: ifcfg.log
Comment 11 Reartes Guillermo 2013-09-16 13:44:47 EDT
Created attachment 798379 [details]
File: packaging.log
Comment 12 Kamil Páral 2013-10-22 04:33:14 EDT
I used manual partitioning, selected an existing partition and wanted to adjust its size. Instead of providing "2 GB" value into the Size field, I used just "2" (no unit). Anaconda crashed after I pressed Update Settings.

cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
cmdline_file:   initrd=initrd0.img root=live:CDLABEL=Fedora-Live-Desktop-x86_64-20-Be rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0  BOOT_IMAGE=vmlinuz0 
hashmarkername: anaconda
kernel:         3.11.5-302.fc20.x86_64
other involved packages: python-blivet-0.23.1-1.fc20.noarch
package:        anaconda-20.25.1-1.fc20.x86_64
packaging.log:  
product:        Fedora
reason:         ValueError: invalid target size request
release:        Fedora release 20 (Heisenbug)
version:        20
Comment 13 Kamil Páral 2013-10-22 04:35:51 EDT
Proposing Beta blocker:
"When using the custom partitioning flow, the installer must be able to:  Reject or disallow invalid disk and volume configurations without crashing. "
https://fedoraproject.org/wiki/Fedora_20_Beta_Release_Criteria#Custom_partitioning
Comment 14 Adam Williamson 2013-10-23 12:54:03 EDT
Discussed at 2013-10-23 blocker review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2013-10-23/f20-blocker-review.2013-10-23-16.00.log.txt .  Accepted as a blocker per criterion cited in comment #13.
Comment 15 Chris Murphy 2013-10-30 14:39:30 EDT
Works for me.

Per c12: test Fedora 20 Beta TC6 with existing Windows7 taking up the entire (qcow2) disk. Clicked on primary partition 2, NTFS, clicked on Desired Capacity and entered in 2 without units and clicked on Update Settings. No crash, Desired Capacity resets to 12.163GB. Click partition "create automatically" link, partitions created. Installs fine. Boots Fedora and Windows as expected.
Comment 16 Adam Williamson 2013-11-06 13:09:40 EST
20.25.4-1 went stable as part of FEDORA-2013-20033, and the fix was verified, so this can be closed.
Comment 17 Martin Krizek 2013-11-07 09:01:00 EST
I reproduced this again with 20.25.6-1 (Fedora 20 Beta RC5). I resized existing logical volume to 100GB and it didn't fail although the disk is only 20GB. Then I resized it again to 100TB and it crashed with attached tb.
Comment 18 Martin Krizek 2013-11-07 09:02:10 EST
Created attachment 821148 [details]
anaconda-tb-bHr5cn
Comment 19 Mike Ruckman 2013-11-07 13:31:15 EST
Discussed in the 2013-11-07 Go/No-Go meeting [1]. Voted as a RejectedBlocker. While unfortunate, resize issues are not covered in the F20 beta release criteria. Thus, this bug is rejected as a release blocking issue for F20 beta. Please re-propose as a F20 final blocker and mark for inclusion in CommonBugs.

[1] http://meetbot.fedoraproject.org/meetbot/meetbot/fedora-meeting-2/2013-11-07/
Comment 20 David Lehman 2013-11-07 15:04:50 EST
(In reply to Martin Krizek from comment #17)
> I reproduced this again with 20.25.6-1 (Fedora 20 Beta RC5). I resized
> existing logical volume to 100GB and it didn't fail although the disk is
> only 20GB. Then I resized it again to 100TB and it crashed with attached tb.

This is a separate bug. Please open a new report for it and include your logs. Thanks.
Comment 21 Adam Williamson 2013-11-07 16:43:28 EST
Correct blocker status (rejected, not accepted).
Comment 22 Adam Williamson 2013-11-12 19:25:09 EST
Per c#20 this should be closed, yes?

Martin, can you please create a new bug as dlehman requested?
Comment 23 Martin Krizek 2013-11-13 04:20:05 EST
I have already done it: bug 1028367