This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1028367 - Invalid resize operation crashes
Invalid resize operation crashes
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
AcceptedBlocker
:
Depends On:
Blocks: F20FinalBlocker
  Show dependency treegraph
 
Reported: 2013-11-08 04:59 EST by Martin Krizek
Modified: 2013-12-02 06:26 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-02 06:26:39 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda.log (29.53 KB, text/x-log)
2013-11-08 05:01 EST, Martin Krizek
no flags Details
anaconda-tb-Sctp28 (599.96 KB, text/plain)
2013-11-08 05:06 EST, Martin Krizek
no flags Details
storage.log (77.49 KB, text/x-log)
2013-11-08 05:14 EST, Martin Krizek
no flags Details

  None (edit)
Description Martin Krizek 2013-11-08 04:59:24 EST
Description of problem:
I resized existing logical volume to 100GB and it didn't fail although the disk is only 20GB. Then I resized it again to 100TB and it crashed with:

Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/blivet/formats/fs.py", line 207, in _setTargetSize
    raise ValueError("invalid target size request")
  File "/usr/lib/python2.7/site-packages/blivet/deviceaction.py", line 589, in __init__
    self.device.format.targetSize = newsize
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 1250, in resizeDevice
    self.devicetree.registerAction(action_class(device, new_size))
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 1454, in _save_right_side
    self.__storage.resizeDevice(device, size)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 2802, in on_apply_clicked
    self._save_right_side(self._current_selector)
ValueError: invalid target size request

Version-Release number of selected component (if applicable):
anaconda 20.25.6-1
python-blivet 0.23.4-1
Fedora 20 Beta RC5

How reproducible:
Always

Actual results:
Crash

Expected results:
Invalid operation is handled properly
Comment 1 Martin Krizek 2013-11-08 05:01:56 EST
Created attachment 821495 [details]
anaconda.log
Comment 2 Martin Krizek 2013-11-08 05:06:42 EST
Created attachment 821496 [details]
anaconda-tb-Sctp28
Comment 3 Martin Krizek 2013-11-08 05:14:29 EST
Created attachment 821497 [details]
storage.log
Comment 4 Martin Krizek 2013-11-13 04:23:51 EST
Proposing as a final blocker, per beta criterion: ""Custom partitioning: Reject or disallow invalid disk and volume configurations without crashing.", with resize issues acceptable as Final blocker.
Comment 5 Adam Williamson 2013-11-13 12:21:48 EST
Discussed at 2013-11-13 blocker review meeting - http://meetbot.fedoraproject.org/fedora-blocker-review/2013-11-13/f20-final-blocker-review-1.2013-11-13-17.01.log.txt . Accepted as a blocker per criterion cited in comment #4, with the note that resize operations are 'blocking' for Final (we need to clarify the criteria to explain why this is Final not Beta blocker).
Comment 6 Adam Williamson 2013-11-20 14:40:23 EST
Status reviewed at 2013-11-20 blocker review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2013-11-20/f20-blocker-review.2013-11-20-17.00.log.txt . This bug seems to be clearly defined and reproducible and is now just waiting in the queue to be fixed by anaconda devs.
Comment 7 Vratislav Podzimek 2013-11-28 07:41:10 EST
Is this still reproducible with F20 TC3?
Comment 8 Martin Krizek 2013-12-02 05:50:21 EST
Can't reproduce it with F20 Final TC3.
Comment 9 Kamil Páral 2013-12-02 06:26:39 EST
In that case we can close this, anaconda 20.25.12 is stable.

Note You need to log in before you can comment on or make changes to this bug.