Bug 1015957

Summary: "Too many open files" before downloading starts
Product: [Fedora] Fedora Reporter: Michal Schmidt <mschmidt>
Component: librepoAssignee: Tomas Mlcoch <tmlcoch>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 20CC: akozumpl, plautrba, tmlcoch
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Fixed In Version: librepo-1.2.1-1.fc20 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-10-09 14:25:29 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Michal Schmidt 2013-10-07 06:35:02 UTC
Description of problem:
I am running into "Too many open files" error when trying to update F19 systems to F20 using dnf. I have previously reported bug 1012290, but the bug I am seeing now is different. This time the error appears even before any package gets downloaded.

Version-Release number of selected component (if applicable):

How reproducible:
always on all F19 systems I tried.

Steps to Reproduce:
1. dnf --releasever=20 --nogpg update fedora-release
2. dnf update rpm dnf librepo
3. dnf distro-sync

Actual results:

Transaction Summary
Install      93 Packages
Upgrade    3266 Packages
Remove        7 Packages
Downgrade    34 Packages

Total download size: 2.9 G
Is this ok [y/N]: y
Downloading Packages:
[Errno unknown] Cannot open /var/cache/dnf/x86_64/20/fedora/packages/python-configobj-4.7.2-7.fc20.noarch.rpm: Too many open files: 'Input/Output error'

Expected results:
Packages downloaded successfully.

Additional info:
When retrying the "dnf distro-sync" command, the same error is reported for the same package as before.
There are 36 zero-length *.rpm files in /var/cache/dnf/x86_64/20/updates-testing/packages.

Comment 1 Tomas Mlcoch 2013-10-07 11:13:26 UTC
*** Bug 1016025 has been marked as a duplicate of this bug. ***

Comment 2 Tomas Mlcoch 2013-10-07 13:55:00 UTC
Build with patch that fixes the issue is available here: http://koji.fedoraproject.org/koji/buildinfo?buildID=469746
It will be pushed to updates soon.

Comment 3 Fedora Update System 2013-10-07 14:01:00 UTC
librepo-1.2.1-1.fc20 has been submitted as an update for Fedora 20.

Comment 4 Fedora Update System 2013-10-07 15:47:51 UTC
Package librepo-1.2.1-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing librepo-1.2.1-1.fc20'
as soon as you are able to.
Please go to the following url:
then log in and leave karma (feedback).

Comment 5 Fedora Update System 2013-10-09 14:25:29 UTC
librepo-1.2.1-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.