Bug 1015957 - "Too many open files" before downloading starts
"Too many open files" before downloading starts
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: librepo (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tomas Mlcoch
Fedora Extras Quality Assurance
:
: 1016025 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-07 02:35 EDT by Michal Schmidt
Modified: 2013-10-09 10:25 EDT (History)
3 users (show)

See Also:
Fixed In Version: librepo-1.2.1-1.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-09 10:25:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Schmidt 2013-10-07 02:35:02 EDT
Description of problem:
I am running into "Too many open files" error when trying to update F19 systems to F20 using dnf. I have previously reported bug 1012290, but the bug I am seeing now is different. This time the error appears even before any package gets downloaded.

Version-Release number of selected component (if applicable):
dnf-0.4.2-1.gitc1716d7.fc20.noarch
librepo-1.2.0-2.fc20.x86_64
hawkey-0.4.2-1.git4c51f65.fc20.x86_64
rpm-4.11.1-7.fc20.x86_64

How reproducible:
always on all F19 systems I tried.

Steps to Reproduce:
1. dnf --releasever=20 --nogpg update fedora-release
2. dnf update rpm dnf librepo
3. dnf distro-sync

Actual results:
...

Transaction Summary
===========================================================================
Install      93 Packages
Upgrade    3266 Packages
Remove        7 Packages
Downgrade    34 Packages

Total download size: 2.9 G
Is this ok [y/N]: y
Downloading Packages:
[Errno unknown] Cannot open /var/cache/dnf/x86_64/20/fedora/packages/python-configobj-4.7.2-7.fc20.noarch.rpm: Too many open files: 'Input/Output error'

Expected results:
Packages downloaded successfully.

Additional info:
When retrying the "dnf distro-sync" command, the same error is reported for the same package as before.
There are 36 zero-length *.rpm files in /var/cache/dnf/x86_64/20/updates-testing/packages.
Comment 1 Tomas Mlcoch 2013-10-07 07:13:26 EDT
*** Bug 1016025 has been marked as a duplicate of this bug. ***
Comment 2 Tomas Mlcoch 2013-10-07 09:55:00 EDT
Build with patch that fixes the issue is available here: http://koji.fedoraproject.org/koji/buildinfo?buildID=469746
It will be pushed to updates soon.
Comment 3 Fedora Update System 2013-10-07 10:01:00 EDT
librepo-1.2.1-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/librepo-1.2.1-1.fc20
Comment 4 Fedora Update System 2013-10-07 11:47:51 EDT
Package librepo-1.2.1-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing librepo-1.2.1-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-18474/librepo-1.2.1-1.fc20
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2013-10-09 10:25:29 EDT
librepo-1.2.1-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.