Bug 1031775

Summary: [RFE] USB Redirection device options in virt-manager
Product: Red Hat Enterprise Linux 7 Reporter: Bill Sanford <bsanford>
Component: virt-managerAssignee: Giuseppe Scrivano <gscrivan>
Status: CLOSED CURRENTRELEASE QA Contact: Virtualization Bugs <virt-bugs>
Severity: medium Docs Contact:
Priority: medium    
Version: 7.0CC: acathrow, avoss, bsanford, codong, dallan, dyuan, gscrivan, lcui, mjenner, mkletzan, mzhan, rmcswain, tzheng, vipatel, zsong
Target Milestone: rcKeywords: FutureFeature
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: virt-manager-0.10.0-1.el7 Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: 964215 Environment:
Last Closed: 2014-06-13 09:32:27 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 964215, 1001999    
Bug Blocks: 807277    

Comment 2 Martin Kletzander 2013-11-19 09:10:42 UTC
This should be available in RHEL 7 ever since.  Is this supposed to be TestOnly bug or am I missing the purpose of this bug?

Comment 3 Bill Sanford 2013-11-19 15:19:51 UTC
USB passthrough for SPICE is not working unless you edit the XML file of the guest. This has been cloned for RHEL 7 after it first appeared and still not fixed in RHEL 6.x.

Comment 4 Martin Kletzander 2013-11-19 16:27:50 UTC
Sorry, I forgot the bug was about SPICE redirection.

Comment 5 Giuseppe Scrivano 2013-11-30 14:06:57 UTC
This is the XML generated when "USB Redirection" with type "SPICE Channel" is added trough the virt-manager interface:

+    <redirdev bus='usb' type='spicevmc'>
+    </redirdev>


The upstream version of virt-manager generates the same XML.  What do you have to modify in order to get it working?

Comment 6 Martin Kletzander 2013-12-03 16:05:02 UTC
Setting needinfo in order to reflect the question in comment #5.

Comment 9 Vimal Patel 2013-12-06 14:38:14 UTC
For Fedora and RHEL to get USB Passthrough working to test it, we have to modify the XML of the VM according to the following:

http://hansdegoede.livejournal.com/11084.html

I thought it would have been a virt-manager option now, since this was introduced in Fedora 16, but that's currently not the case.

Comment 10 Giuseppe Scrivano 2013-12-06 15:09:33 UTC
what version of Fedora are you using?  The virt-manager available on my Fedora 19 (virt-manager-0.10.0-4.fc19.noarch) has the capability to add an USB Redirection device and to specify SPICE as type.  Could you please verify it?

that has the effect of adding the following XML to the VM definition:

+    <redirdev bus='usb' type='spicevmc'>
+    </redirdev>

Comment 11 Vimal Patel 2013-12-06 15:44:18 UTC
Hi Giuseppe, last time we tried F19 spice USB redirection was not working, I don't know what version, but we don't really test Fedora, mostly just RHEL.  So maybe it has been updated.  It just needs to be defined as the link defines it in Comment 9.

Comment 12 Vimal Patel 2013-12-06 16:18:53 UTC
Hi Giuseppe, 
I modified an xml and just added those two lines and usb redirection does work as expected, so that should be what we need.

Comment 17 zhengqin 2013-12-11 11:05:50 UTC
Retest it with virt-manager-0.10.0-8.el7, USB Redirection device options have been added into virt-manager, and usb device could be redirected into guest.

So, set the status as "VERIFIED"

Comment 18 zhengqin 2013-12-11 11:20:42 UTC
Retest steps:
1. Prepare a spice guest which is in stopped status.
2. Plug the USB disk into Host
3. Open virt-manager -> spiceGuest -> View -> Details -> Add Hardware -> USB Redirection and choose Spice channel Type, then click Finish.
4. Start this spice guest, then open virt-manager -> spiceGuest -> Virtual Machine -> Redirect USB device, then choose your usb disk and click OK button.
5. From the guest, we could see this newly added usb disk.

Comment 20 Ludek Smid 2014-06-13 09:32:27 UTC
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.