Bug 964215 - [RFE] USB Redirection device options in virt-manager
[RFE] USB Redirection device options in virt-manager
Status: CLOSED DUPLICATE of bug 807277
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-manager (Show other bugs)
6.3
All Linux
medium Severity medium
: rc
: ---
Assigned To: Giuseppe Scrivano
Virtualization Bugs
: FutureFeature
Depends On: 1001999
Blocks: 807277 1031775
  Show dependency treegraph
 
Reported: 2013-05-17 10:50 EDT by Allan Voss
Modified: 2014-02-04 08:27 EST (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
: 1001999 1031775 (view as bug list)
Environment:
Last Closed: 2014-02-04 08:27:15 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Allan Voss 2013-05-17 10:50:51 EDT
Allow for the configuration of USB Passthrough from the virsh and virt-manager systems so that manual editing of XML files isn't necessary
Comment 5 Robert McSwain 2013-05-31 09:41:13 EDT
Hello,

Here is what the enhancement requester states about the requested information:

• For USB redirection from Client (where the client does not need to be the host) to VM:
- Host/Client: usbredir package, It's in standard RHEL6 channel and qemu on the host needs to be set with correct options, which are not exposed in RHEL6 virt-manager but can be set manually using command line tool "virsh" according to the blog post - http://hansdegoede.livejournal.com/11084.html.

note the "which are not exposed in RHEL6 virt-manager but can be set manually" pieces.

• USB Redirection never worked properly in virt-manager throughout all our testing. Haven't retested with virt-manager since making the manual changes specified above. Spicy certainly started working.

• Red Hat providing a script to make the above changes would be useful. Or supporting the above setup in the virt-manager GUI. One should not be forced to go into virsh edit domain and manually edit xml to make usb redirection work.

Please feel free to let me know if there's anything else I can do to help keep this bug moving along.
Comment 6 Martin Kletzander 2013-08-01 09:38:56 EDT
I'm getting back to this bug after a while since it's not the highest priority right now, sorry for that.  It's still not clear to me what's the requested work, but is it maybe what is written in BZ 807277 as well?  Thanks for the info.  In case the BZs are requesting the same behavior/information, feel free to either mark it as a duplicate or let me know and I'll handle the situation.  Thanks.
Comment 10 Martin Kletzander 2013-08-02 00:35:27 EDT
Fixed in upstream commit RELEASE-0.9.0-1-41-gfaf93c0:

commit faf93c0f8f656ae4e2ff69ca37f1f7d5804ef894
Author: Marc-André Lureau <marcandre.lureau@gmail.com>
Date:   Fri Sep 2 03:23:28 2011 +0200

    virt-manager: Learn to add USB redirection devices
Comment 16 Giuseppe Scrivano 2014-02-04 08:27:15 EST
closing as a DUP as this feature is a subset of what needs to be done for 807277.

*** This bug has been marked as a duplicate of bug 807277 ***

Note You need to log in before you can comment on or make changes to this bug.