Bug 104178

Summary: regression (?) in auto-hide behavior
Product: [Fedora] Fedora Reporter: Alexandre Oliva <oliva>
Component: gnome-panelAssignee: Mark McLoughlin <markmc>
Status: CLOSED ERRATA QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 1CC: bart.martens, leonard-rh-bugzilla, marcjw53
Target Milestone: ---Keywords: MoveUpstream, Triaged
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: 2.4.2-3 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2004-03-02 10:49:14 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
gnome-panel-2.4.0-unhide.patch none

Description Alexandre Oliva 2003-09-10 16:47:37 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703

Description of problem:
If the panel is in auto-hide mode and you just float the mouse over its
displayed portion, and quickly move it away from the panel before it unhides,
the panel will remain unhidden.

Version-Release number of selected component (if applicable):
gnome-panel-2.3.90-1

How reproducible:
Always

Steps to Reproduce:
1.Quickly move the mouse so as to unhide the panel, but move it away before it
actually unhides

Actual Results:  It unhides, but doesn't hide again

Expected Results:  It should.  I think it used to, but I may just be tripping
over the unhidden region more often because it got thicker

Additional info:

I doubt this makes a difference, but I have focus-follows-mouse enabled.
Comment 1 Alexandre Oliva 2003-10-19 15:36:34 EDT
I've relized this may actually be a feature, not a bug.  There are cases in
which it's nice to be able to keep the panel displayed even though the mouse is
no longer on it.  Still, it would be nice to know whether it was a conscious
decision or an accident.
Comment 2 Motor 2003-11-15 12:07:00 EST
The panel autohiding also seems to be broken in the following way:

The unhide_delay (gconf setting) in popping up the panel is,
presumably, supposed to allow the mouse to stray over that area
momentarily without popping up the panel -- which can be irritating if
you are trying to mouse in the area. 

However, in Fedora core 1, the delay really is just a delay in
appearing. If you set the unhide_delay of the panel to something like
1000 you can see the effect very clearly. Flick the mouse over to the
panel and away to the other side of the screen again quickly. To make
any sense of the delay, the panel should not appear... the mouse was
not in the pop up area long enough to activate it. However, the panel
will eventually pop up! And what's worse, it will remain there because
there's no exit event since the mouse left ages ago.

This seems like broken behaviour to me... unless the delay is for some
other reason.
Comment 3 Bart Martens 2004-02-05 20:49:24 EST
Created attachment 97508 [details]
gnome-panel-2.4.0-unhide.patch
Comment 4 Todd Wilson 2004-02-07 18:28:43 EST
I see that Bart Martens has already posted a patch (Comment #3), but I
would nevertheless like to add, at his request and for the record,
that the default behavior when touching an autohide panel in Red Hat
9.0 is that the panel does not unhide if the mouse comes off of the
panel before it opens (i.e., unhide_delay expires).  This, to me, is
the preferred behavior, because it is often the case that my pointer
is moving near the hidden panel and touches it only accidentally, in
which case I don't want it to unhide.

The situation described in Comment #1, where it is nice to keep the
panel open, could be better achieved through a non-autohide panel that
can be manually hidden and unhidden when desired.
Comment 5 Miloslav Trmac 2004-02-17 14:39:22 EST
*** Bug 111045 has been marked as a duplicate of this bug. ***
Comment 6 Mark McLoughlin 2004-02-20 09:06:25 EST
Okay, this is fix in 2.4.2 and HEAD, so the fix is in Raw Hide. The
exact upstream fix was:

2003-11-20  Vincent Untz  <vincent@vuntz.net>
                                                                     
                                                                         
        * panel-toplevel.c: (panel_toplevel_auto_unhide_timeout_handler): 
        do not stop unhiding the panel if the cursor is not in the panel 
        but the auto_hide property is FALSE.

However, Bart - your fix is actually closer being the correct fix, so
I'm going to commit something similar on HEAD soon.


I'll close this when I release an FC1 update with 2.4.2.
Comment 7 Mark McLoughlin 2004-02-23 17:42:37 EST
I've just released a testing update which should fix this issue.
Please test it out and let us know if it fixes your problem.

Details on the update:
http://www.redhat.com/archives/fedora-test-list/2004-February/msg01512.html
Comment 8 Marc Williams 2004-02-23 18:15:59 EST
Looks good so far.  Can add more than 2 apps to drawer and my panel
doesn't pop up when lightly touched.  Thanks!

I notice that the FC1 drawer doesn't have an autohide option i.e. the
drawer disappears after selecting an item in it.  But I could've sworn
that my RH 8.0 drawer had an autohide, yes?
Comment 9 Mark McLoughlin 2004-03-02 10:49:14 EST
Okay, a gnome-panel Fedora Core 1 Update (2.4.2-3) with a fix
for this bug is now available from:

   http://download.fedora.redhat.com/pub/fedora/linux/core/updates/1/