Bug 1044905

Summary: sssd_nss grows memory footprint when netgroups are requested
Product: Red Hat Enterprise Linux 6 Reporter: Jan Kurik <jkurik>
Component: sssdAssignee: Jakub Hrozek <jhrozek>
Status: CLOSED ERRATA QA Contact: Kaushik Banerjee <kbanerje>
Severity: high Docs Contact:
Priority: high    
Version: 6.4CC: dpal, ekeck, grajaiya, jgalipea, jhrozek, jkurik, lslebodn, mkosek, pbrezina, pm-eus, rvokal
Target Milestone: rcKeywords: ZStream
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: sssd-1.9.2-129.el6_5.4 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-01-06 08:36:58 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1038098    
Bug Blocks:    

Description Jan Kurik 2013-12-19 08:42:27 UTC
This bug has been copied from bug #1038098 and has been proposed
to be backported to 6.5 z-stream (EUS).

Comment 5 Kaushik Banerjee 2013-12-27 07:26:40 UTC
Verified in version 1.9.2-129.el6_5.4

Report from beaker job run:
::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::
:: [   LOG    ] :: netgroup_bug_06: BZ 1040969 sssd_nss grows memory footprint
::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::

:: [   PASS   ] :: sssd_nss is not leaking memory during netgroup lookup 
:: [   LOG    ] :: Duration: 3m 23s
:: [   LOG    ] :: Assertions: 1 good, 0 bad
:: [   PASS   ] :: RESULT: netgroup_bug_06: BZ 1040969 sssd_nss grows memory footprint

Comment 7 errata-xmlrpc 2014-01-06 08:36:58 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0005.html