Bug 1038098 - sssd_nss grows memory footprint when netgroups are requested
Summary: sssd_nss grows memory footprint when netgroups are requested
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: sssd
Version: 6.4
Hardware: x86_64
OS: Linux
high
high
Target Milestone: rc
: 6.5
Assignee: Jakub Hrozek
QA Contact: Kaushik Banerjee
URL:
Whiteboard:
Depends On: 1023409
Blocks: 1040969 1044905
TreeView+ depends on / blocked
 
Reported: 2013-12-04 12:13 UTC by Rui Gouveia
Modified: 2018-12-06 15:32 UTC (History)
14 users (show)

Fixed In Version: sssd-1.9.2-132.el6
Doc Type: Bug Fix
Doc Text:
Cause: Memory was not freed corectly Consequence: Memory growth if the application requesting netgroups was a long-running one Fix: Memory is freed corectly Result: Memory is no longer leaking even in long-running applications
Clone Of: 1023409
: 1040969 (view as bug list)
Environment:
Last Closed: 2014-10-14 04:47:23 UTC
Target Upstream Version:


Attachments (Terms of Use)
source code of reproducer (667 bytes, text/x-csrc)
2013-12-04 15:00 UTC, Lukas Slebodnik
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1375 normal SHIPPED_LIVE sssd bug fix and enhancement update 2014-10-14 01:06:25 UTC

Comment 1 Jakub Hrozek 2013-12-04 14:21:22 UTC
The valgrind error was not related after all. We found out that we didn't free a memory context where we should, which resulted in memory growth if the application requesting netgroups was a long-running one.

To reproduce:
1) Run a process that requests a netgroup periodically but doesn't exit between the attempts. Maybe a deamon, python interpreter might do as well.
2) Watch the sssd_nss memory footprint grow

Comment 2 Jakub Hrozek 2013-12-04 14:24:37 UTC
Upstream ticket:
https://fedorahosted.org/sssd/ticket/2170

Comment 3 Lukas Slebodnik 2013-12-04 15:00:40 UTC
Created attachment 832692 [details]
source code of reproducer

Bug can be reproduced with attached example program.

gcc -Wall netgroup.c -o netgroup
./netgroup netgroup_name

Memory leak is reproducible also with non-existing netgroup.
RSS of sssd_nss process was increased about 200 MB in 3 minutes.

Comment 4 Jakub Hrozek 2013-12-10 11:10:43 UTC
Fixed upstream:
 * master: 65f4003b93157b32eb0dcd6955d37dd009dc960e
 * sssd-1-11: 8696135e659685394937f81136521c676f0a0678
 * sssd-1-9: 34728310b600c700188b2679118a1af85bcdaaaf

Comment 8 Jakub Hrozek 2013-12-12 12:21:36 UTC
The bug has been fixed upstream in all supported branches.

Comment 17 Nirupama Karandikar 2014-07-30 11:14:51 UTC
Tested with sssd-1.11.6-12.el6.x86_64

Verified via beaker run.

https://beaker.engineering.redhat.com/jobs/707409

Comment 18 errata-xmlrpc 2014-10-14 04:47:23 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1375.html


Note You need to log in before you can comment on or make changes to this bug.