Bug 1049867

Summary: After laptop suspect, previously connected mounts hang Nautilus completely
Product: [Fedora] Fedora Reporter: Greg Harvey <gharveyatwork>
Component: gvfsAssignee: Matthias Clasen <mclasen>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 20CC: alexl, bnocera, ccecchi, mclasen, oholy
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-01-09 08:37:28 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Greg Harvey 2014-01-08 11:51:25 UTC
Description of problem:

I have a couple of machines on my LAN that I routinely connect to via Nautilus: one is a Buffalo Linkstation NAS that exposes itself in various ways, as an SMB Windows share but also via AFP; the other is an old machine still running Fedora 14 that I connect to with SSH (SFTP). When I installed Fedora 20 on my new laptop I connected to it in the usual way (browse network, double-click server, double-click share, authenticate and in you go). All works fine, but if you suspend the laptop and then go back to Files on resume, Nautilus has hung - seems as though it is hung waiting for a mount to respond? That's a guess, I don't know what data you'd need to verify this, but happy to supply it. For now I will connect to one protocol at a time and see if I can narrow it down to a specific mount that's causing the issue.

Version-Release number of selected component (if applicable):

3.10.1

How reproducible:

For me this happens every time I forget to unmount the mounts I use frequently, but as yet I haven't isolated a specific mount or protocol.

Steps to Reproduce:

1. Open Files in GNOME3 and connect to a few network drives (in my case, there was an AFP mount, a SFTP mount and, occasionally, a SMB mount too);
2. Browse around, make sure they are all connected and working as expected;
3. Suspend your computer and leave it for a while;
4. Resume the computer and go back to Files.

Actual results:

Files will have frozen and it won't recover.

Expected results:

Files continues without issue and doesn't hang, if network shares have been disconnected they gracefully drop off.

Additional info:

To follow...

Comment 1 Greg Harvey 2014-01-09 08:37:28 UTC
I'm going to close this as a dupe, because after more testing I narrowed it down to the AFP protocol specifically (samba and ssh seem stable) and I found the referenced report, which is pretty much what I'm seeing. Seems it appears in Ubuntu too, so it's probably upstream in gvfs, specifically gvfsd-afp.

*** This bug has been marked as a duplicate of bug 1001320 ***