Bug 1001320 - gvfs-afp pegs CPU when WD MyBookLive "NAS" device offers AFP service
gvfs-afp pegs CPU when WD MyBookLive "NAS" device offers AFP service
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: gvfs (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ondrej Holy
Fedora Extras Quality Assurance
:
: 1049867 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-26 17:38 EDT by Martin Langhoff
Modified: 2014-09-15 13:08 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-09-15 13:08:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Langhoff 2013-08-26 17:38:33 EDT
Description of problem:

A laggy F19 desktop since I started using a Western Digital "MyBookLive" NAS in my home network. The NAS is mounted over NFS on this F19 box. However, gfvsd-afp-browse is spinning wild, as can be seen in:

$ ps ax | grep gvfsd
 1624 ?        Sl     0:00 /usr/libexec/gvfsd
 1629 ?        Sl     0:00 /usr/libexec//gvfsd-fuse -f /run/user/500/gvfs
 2069 ?        Sl     0:00 /usr/libexec/gvfsd-burn --spawner :1.3 /org/gtk/gvfs/exec_spaw/0
 6937 ?        Sl     0:00 /usr/libexec/gvfsd-network --spawner :1.3 /org/gtk/gvfs/exec_spaw/3
 6949 ?        Sl     0:00 /usr/libexec/gvfsd-dnssd --spawner :1.3 /org/gtk/gvfs/exec_spaw/5
 6962 ?        RLl  1607:19 /usr/libexec/gvfsd-afp-browse --spawner :1.3 /org/gtk/gvfs/exec_spaw/7
 7021 ?        Sl     0:00 /usr/libexec/gvfsd-metadata
 7920 ?        Sl     0:00 /usr/libexec/gvfsd-smb-browse --spawner :1.3 /org/gtk/gvfs/exec_spaw/11
17459 ?        Sl     0:11 /usr/libexec/gvfsd-trash --spawner :1.3 /org/gtk/gvfs/exec_spaw/1
18734 ?        Sl     0:00 /usr/libexec/gvfsd-http --spawner :1.3 /org/gtk/gvfs/exec_spaw/2


Version-Release number of selected component (if applicable):

 gvfs-afp.x86_64 0:1.16.3-2.fc19  

How reproducible:

Seems to repro 100% here. 

I have removed the package for now, I will be happy to reinstall and debug if I can get some pointers of what to look for.

There are macs in this network that make good use of the AFP service (Time Machine, cute). Switching AFP off at the NAS is not an option.
Comment 1 Martin Langhoff 2013-08-26 17:40:13 EDT
FWIW: very similar bug report on Ubuntu -https://bugs.launchpad.net/ubuntu/+source/gvfs/+bug/951585
Comment 2 Greg Harvey 2014-01-09 03:37:28 EST
*** Bug 1049867 has been marked as a duplicate of this bug. ***
Comment 3 Greg Harvey 2014-01-09 03:41:42 EST
This is still happening in Fedora 20, I marked #1001320 as a duplicate after further investigation. Having tested the various different mounts I was using, turns out my nautilus issues were actually wholly gvfsd-afp issues. In my case the NAS is a Buffalo Linkstation, but the result is the same. The same NAS offers a samba share which works fine, they afp share is unusable and crashes the file browser.
Comment 4 Ross Lagerwall 2014-08-27 03:16:32 EDT
This is upstream bug https://bugzilla.gnome.org/show_bug.cgi?id=710490 and has been fixed.

Note You need to log in before you can comment on or make changes to this bug.