Bug 1053349

Summary: sddm declines password entry
Product: [Fedora] Fedora Reporter: Hakan Duran <hakan_duran>
Component: selinux-policyAssignee: Miroslav Grepl <mgrepl>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: unspecified    
Version: rawhideCC: dominick.grift, dvratil, dwalsh, hakan_duran, jgrulich, kevin, ltinkl, lvrabec, mbriza, mgrepl, rdieter
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-01-15 17:52:16 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Hakan Duran 2014-01-15 04:54:29 UTC
Description of problem:
Login manager SDDM greets, user name and password entry is rejected.

Version-Release number of selected component (if applicable):
Fedora 21 rawhide

How reproducible:
Always

Steps to Reproduce:
1. Start virtual machine
2. Finish booting, SDDM greeting screen appears
3. Username and password entered
4. "Login failed" message appears under the password field in red font. This happens both for regular user and root.
5. Switch to virtual terminal, e.g. tty2. Login using the same username and password without problem.

Actual results:
Failed login to kde through sddm.

Expected results:
Successful login to kde through sddm.

Additional info:
1. startx command from tty2 launches kde without problem.
2. Disabling sddm and enabling lightdm through systemd is a workaround that works.

Comment 1 Kevin Kofler 2014-01-15 17:48:09 UTC
On IRC (#fedora-kde), we traced this to SELinux.

Comment 2 Kevin Kofler 2014-01-15 17:52:16 UTC

*** This bug has been marked as a duplicate of bug 1052317 ***