Bug 1059391

Summary: Future parser doesn't work due to missing rgen dependency
Product: [Fedora] Fedora Reporter: Sam Kottler <skottler>
Component: puppetAssignee: Jeroen van Meeuwen <vanmeeuwen+fedora>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: dcleal, fedora, jose.p.oliveira.oss, k.georgiou, mastahnke, mmagr, moses, ohadlevy, skottler, tmz, vanmeeuwen+fedora
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1051613 Environment:
Last Closed: 2014-02-10 17:32:28 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1051613, 1051901, 1059395, 1059397    
Bug Blocks:    

Description Sam Kottler 2014-01-29 18:43:08 UTC
+++ This bug was initially created as a clone of Bug #1051613 +++

Description of problem:
The experimental future parser in Puppet isn't working as the "rgen" dependency is missing.

Version-Release number of selected component (if applicable):
puppet-3.3.1-1.fc19.noarch

How reproducible:
Always

Steps to Reproduce:
1. puppet apply -e 'notice([1, 2][1])' --parser future

Actual results:
Error: Could not parse for environment production: The gem 'rgen' version >= 0.6.1 is required when using the setting '--parser future'. Please install 'rgen'. on node plain.example.com
Error: Could not parse for environment production: The gem 'rgen' version >= 0.6.1 is required when using the setting '--parser future'. Please install 'rgen'. on node plain.example.com

Expected results:
Notice: Scope(Class[main]): 2
Notice: Compiled catalog for plain.example.com in environment production in 0.31 seconds

Additional info:
ruby-rgen is packaged by Puppet Labs upstream, though I do wonder if it should be a rubygem instead, since that's how it's actually distributed by rgen.  It appears that PL have unpacked the gem and repackaged as a plain ruby package.

http://docs.puppetlabs.com/puppet/3/reference/experiments_future.html