Bug 1051613 - Future parser doesn't work due to missing rgen dependency
Summary: Future parser doesn't work due to missing rgen dependency
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: puppet
Version: 19
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Sam Kottler
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1051901
Blocks: 1059391 1059395 1059397
TreeView+ depends on / blocked
 
Reported: 2014-01-10 17:01 UTC by Dominic Cleal
Modified: 2014-06-18 08:14 UTC (History)
10 users (show)

Fixed In Version: puppet-3.4.2-2.fc19
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1059391 1059395 1059397 (view as bug list)
Environment:
Last Closed: 2014-03-03 03:12:08 UTC


Attachments (Terms of Use)

Description Dominic Cleal 2014-01-10 17:01:29 UTC
Description of problem:
The experimental future parser in Puppet isn't working as the "rgen" dependency is missing.

Version-Release number of selected component (if applicable):
puppet-3.3.1-1.fc19.noarch

How reproducible:
Always

Steps to Reproduce:
1. puppet apply -e 'notice([1, 2][1])' --parser future

Actual results:
Error: Could not parse for environment production: The gem 'rgen' version >= 0.6.1 is required when using the setting '--parser future'. Please install 'rgen'. on node plain.example.com
Error: Could not parse for environment production: The gem 'rgen' version >= 0.6.1 is required when using the setting '--parser future'. Please install 'rgen'. on node plain.example.com

Expected results:
Notice: Scope(Class[main]): 2
Notice: Compiled catalog for plain.example.com in environment production in 0.31 seconds

Additional info:
ruby-rgen is packaged by Puppet Labs upstream, though I do wonder if it should be a rubygem instead, since that's how it's actually distributed by rgen.  It appears that PL have unpacked the gem and repackaged as a plain ruby package.

http://docs.puppetlabs.com/puppet/3/reference/experiments_future.html

Comment 1 Fedora Update System 2014-02-10 17:40:03 UTC
puppet-3.4.2-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/puppet-3.4.2-2.fc19

Comment 2 Fedora Update System 2014-02-11 23:16:46 UTC
Package puppet-3.4.2-2.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing puppet-3.4.2-2.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-2320/puppet-3.4.2-2.fc19
then log in and leave karma (feedback).

Comment 3 Fedora Update System 2014-03-03 03:12:08 UTC
puppet-3.4.2-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.