Bug 1063762

Summary: [RHEVM] [webadmin] [network labels] cannot remove network label from interface via Setup Host Networks
Product: [Retired] oVirt Reporter: Martin Pavlik <mpavlik>
Component: ovirt-engine-webadminAssignee: Alona Kaplan <alkaplan>
Status: CLOSED CURRENTRELEASE QA Contact: Martin Pavlik <mpavlik>
Severity: high Docs Contact:
Priority: high    
Version: 3.4CC: acathrow, ecohen, gklein, iheim, knesenko, lvernia, mgoldboi, myakove, nyechiel, Rhev-m-bugs, yeylon
Target Milestone: ---Keywords: Triaged
Target Release: 3.4.0   
Hardware: x86_64   
OS: Linux   
Whiteboard: network
Fixed In Version: ovirt-3.4.0-ga Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-03-31 12:25:48 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1024889    

Description Martin Pavlik 2014-02-11 11:56:03 UTC
Description of problem:
cannot remove network label from interface via Setup Host Networks

Version-Release number of selected component (if applicable):
oVirt Engine Version: 3.4.0-0.7.beta2.el6 

How reproducible:
100%

Steps to Reproduce:
1. Hosts -> your host -> Network Interfaces -> Setup Host Networks
2. Click on the pencil icon on mangement _interface_ (e.g. em1)
3. fill in label (e.g. lb_ovirtmgmt) -> click OK
4. Click on the pencil icon on mangement _interface_ (e.g. em1)
5. delete the previously assigned label -> click OK
6. Click on the pencil icon on mangement _interface_ (e.g. em1)

Actual results:
label assigned in step 3 is still present

Expected results:
interface should have no label

Additional info:

2014-02-11 12:46:50,043 INFO  [org.ovirt.engine.core.bll.network.host.SetupNetworksCommand] (ajp--127.0.0.1-8702-7) [7b65b666] Running command: SetupNetworksCommand internal: false. Entities affected :  ID: 78bd31f7-b59b-4e09-a807-6c415c38cb03 Type: VDS

Comment 1 Martin Pavlik 2014-03-10 13:18:10 UTC
bug still reproducible in av2.1
Red Hat Enterprise Virtualization Manager Version: 3.4.0-0.3.master.el6ev

Comment 2 Alona Kaplan 2014-03-10 13:42:36 UTC
Moved by mistake to on_qa.

Comment 3 Meni Yakove 2014-03-16 14:07:11 UTC
rhevm-3.4.0-0.5.master.el6ev.noarch

Comment 4 Sandro Bonazzola 2014-03-31 12:25:48 UTC
this is an automated message: moving to Closed CURRENT RELEASE since oVirt 3.4.0 has been released