Bug 1063762 - [RHEVM] [webadmin] [network labels] cannot remove network label from interface via Setup Host Networks
Summary: [RHEVM] [webadmin] [network labels] cannot remove network label from interfac...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-webadmin
Version: 3.4
Hardware: x86_64
OS: Linux
high
high
Target Milestone: ---
: 3.4.0
Assignee: Alona Kaplan
QA Contact: Martin Pavlik
URL:
Whiteboard: network
Depends On:
Blocks: 1024889
TreeView+ depends on / blocked
 
Reported: 2014-02-11 11:56 UTC by Martin Pavlik
Modified: 2014-04-01 04:57 UTC (History)
11 users (show)

Fixed In Version: ovirt-3.4.0-ga
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-03-31 12:25:48 UTC
oVirt Team: ---


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 24931 0 None None None Never
oVirt gerrit 25380 0 None MERGED wedamdin: NPE when removing label from interface/bond Never
oVirt gerrit 25458 0 None MERGED wedamdin: NPE when removing label from interface/bond Never

Description Martin Pavlik 2014-02-11 11:56:03 UTC
Description of problem:
cannot remove network label from interface via Setup Host Networks

Version-Release number of selected component (if applicable):
oVirt Engine Version: 3.4.0-0.7.beta2.el6 

How reproducible:
100%

Steps to Reproduce:
1. Hosts -> your host -> Network Interfaces -> Setup Host Networks
2. Click on the pencil icon on mangement _interface_ (e.g. em1)
3. fill in label (e.g. lb_ovirtmgmt) -> click OK
4. Click on the pencil icon on mangement _interface_ (e.g. em1)
5. delete the previously assigned label -> click OK
6. Click on the pencil icon on mangement _interface_ (e.g. em1)

Actual results:
label assigned in step 3 is still present

Expected results:
interface should have no label

Additional info:

2014-02-11 12:46:50,043 INFO  [org.ovirt.engine.core.bll.network.host.SetupNetworksCommand] (ajp--127.0.0.1-8702-7) [7b65b666] Running command: SetupNetworksCommand internal: false. Entities affected :  ID: 78bd31f7-b59b-4e09-a807-6c415c38cb03 Type: VDS

Comment 1 Martin Pavlik 2014-03-10 13:18:10 UTC
bug still reproducible in av2.1
Red Hat Enterprise Virtualization Manager Version: 3.4.0-0.3.master.el6ev

Comment 2 Alona Kaplan 2014-03-10 13:42:36 UTC
Moved by mistake to on_qa.

Comment 3 Meni Yakove 2014-03-16 14:07:11 UTC
rhevm-3.4.0-0.5.master.el6ev.noarch

Comment 4 Sandro Bonazzola 2014-03-31 12:25:48 UTC
this is an automated message: moving to Closed CURRENT RELEASE since oVirt 3.4.0 has been released


Note You need to log in before you can comment on or make changes to this bug.