Bug 10694

Summary: Installer autochose workstation, then formatted disks
Product: [Retired] Red Hat Linux Reporter: csewhiz
Component: installerAssignee: Matt Wilson <msw>
Severity: high Docs Contact:
Priority: medium    
Version: 6.2   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2000-04-13 14:17:17 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Description Flags
patch applied to never move to IntelliMouse protocol none

Description csewhiz 2000-04-10 13:01:27 UTC
I upgraded my 6.1 system to 6.2.

Using the boot disk, It booted then asked me for mouse type (intimouse
serial) and video montor.

Then the next screen I saw was enter admin password and new user.
Foolishly I pressed next, next hoping to get to the main choice screen to
choose Upgrade.  Even when it said "now writing data to your hard disk" I
pressed return (I didn't think it would do anything serious without showing
the "main" selection screen).  I was wrong, and it overwrote my 6.1 system.

In intalling it again, the installer had autochosen, the defaults for
"Install Worstation", "loose data" screen. Without showing any of the
screens and left me at the enter root password screen.

The back button is enabled, so it is possible to go back - BUT....
this is definately not how I expected the install to work.

Currently I am rebuilding my system, from all those backups I should have

Comment 1 Matt Wilson 2000-04-11 16:44:59 UTC
Unfortunately, the IntelliMouse protocol requires a mouse reset to properly
work.  When you select different mouse protocols in the mouse configuration
screen, we tell the X server to switch to use the new protocol.  There seems to
be a problem when switching to IMPS or IntelliMouse.  The X server sends data to
the mouse to get it to switch modes, but this data is echoed and interpreted as
mouse clicks.

I ran into this problem on PS/2 IntelliMouse and fixed it before we shipped
6.2.  I saw the behavior on the serial IntelliMouse, made some changs, and had
it working, but it seems that there was a regression before we shipped.

To prevent this from happening in the future, I've modified the installer to
never switch to IntelliMouse protocols.

Apologies for you loss of data.  Protecting our customer's data is our #1
concern here.  This is why we've expanded the warning text on the "about to
install" screen, "this is the last point at which you can abort the installation

I'll make sure this won't happen again.

Comment 2 Matt Wilson 2000-04-11 16:45:59 UTC
Created attachment 192 [details]
patch applied to never move to IntelliMouse protocol

Comment 3 Michael Fulbright 2000-04-13 14:17:59 UTC
*** This bug has been marked as a duplicate of 10456 ***

Comment 4 Ryan Jonasson 2000-04-13 17:41:59 UTC
*** Bug 10456 has been marked as a duplicate of this bug. ***