Bug 1081561

Summary: CA not start during ipa server install in pure IPv6 env
Product: Red Hat Enterprise Linux 7 Reporter: Xiyang Dong <xdong>
Component: ipaAssignee: IPA Maintainers <ipa-maint>
Status: CLOSED ERRATA QA Contact: Xiyang Dong <xdong>
Severity: unspecified Docs Contact:
Priority: medium    
Version: 7.0CC: alee, ipa-qe, jcholast, ksiddiqu, mbasti, mkolaja, nsoman, pvoborni, rcritten, xdong
Target Milestone: rc   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 1082663 (view as bug list) Environment:
Last Closed: 2017-08-01 09:37:23 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1082663    
Bug Blocks: 1366991    
Attachments:
Description Flags
ipaserver-install.log
none
pkispawn.log
none
pki_ca_debug.log none

Description Xiyang Dong 2014-03-27 14:56:07 UTC
Description of problem:
ipa server install ended with "CA did not start in 300s" in pure IPv6 env 

Version-Release number of selected component (if applicable):
ipa-server-3.3.3-27.el7.x86_64

How reproducible:
Always

Steps to Reproduce:
1.In /etc/hosts
Remove : 127.0.0.1 localhost localhost.localdomain localhost4 localhost4.localdomain4
Add         : <ipv6> <hostname> <shortname> (IP FQDN shortname)
2.delete ipv4 address
3.stop ip6tables
4.ipa-server-install

Actual results:
install is not finished with 
'CA did not start in 300s'

Expected results:
install is successfull

Additional info:
[root@70ms ~]# cat /etc/hosts
::1 localhost localhost.localdomain localhost6 localhost6.localdomain6
2620:52:0:1040:9e8e:99ff:fe4c:1320 70ms.testrelm.com 70ms
[root@70ms ~]# ip addr del 127.0.0.1 dev lo
Warning: Executing wildcard deletion to stay compatible with old scripts.
Explicitly specify the prefix length (127.0.0.1/32) to avoid this warning.
This special behaviour is likely to disappear in further releases,
fix your scripts!

[root@70ms ~]# ip -4 addr del 10.16.65.49 dev eno1
Warning: Executing wildcard deletion to stay compatible with old scripts.
Explicitly specify the prefix length (10.16.65.49/32) to avoid this warning.
This special behaviour is likely to disappear in further releases,
fix your scripts!

If master is getting disconnected after deleting ipv4 addr,
try to ssh -6 with ipv6 addr from replica:

[root@70replica ~]# ssh -6 2620:52:0:1040:9e8e:99ff:fe4c:1320
The authenticity of host '2620:52:0:1040:9e8e:99ff:fe4c:1320 (2620:52:0:1040:9e8e:99ff:fe4c:1320)' can't be established.
ECDSA key fingerprint is cc:95:6b:33:b0:95:31:7f:16:b2:86:42:71:1c:95:52.
Are you sure you want to continue connecting (yes/no)? yes
Warning: Permanently added '2620:52:0:1040:9e8e:99ff:fe4c:1320' (ECDSA) to the list of known hosts.
Last login: Thu Mar 27 09:03:41 2014 from 10.18.57.8
** ** ** ** ** ** ** ** ** ** ** ** ** ** ** ** ** **
This System is reserved by xdong@redhat.com.

To return this system early. You can run the command: return2beaker.sh
Ensure you have your logs off the system before returning to Beaker

To extend your reservation time. You can run the command:
extendtesttime.sh
This is an interactive script. You will be prompted for how many
hours you would like to extend the reservation.

You should verify the watchdog was updated succesfully after
you extend your reservation.
https://beaker.engineering.redhat.com/recipes/1286472

For ssh, kvm, serial and power control operations please look here:
https://beaker.engineering.redhat.com/view/hp-ml350gen8-01.rhts.eng.bos.redhat.com

For the default root password, see:
https://beaker.engineering.redhat.com/prefs/

Beaker Test information:
HOSTNAME=hp-ml350gen8-01.rhts.eng.bos.redhat.com
JOBID=620571
RECIPEID=1286472
RESULT_SERVER=127.0.0.1:7092
DISTRO=RHEL-7.0-20140320.0
ARCHITECTURE=x86_64

Job Whiteboard: IPV6 test env -- master 3

Recipe Whiteboard: IPA MASTER
** ** ** ** ** ** ** ** ** ** ** ** ** ** ** ** ** **
[root@70ms ~]# ip a
1: lo: mtu 65536 qdisc noqueue state UNKNOWN
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet6 ::1/128 scope host
valid_lft forever preferred_lft forever
2: eno1: mtu 1500 qdisc mq state UP qlen 1000
link/ether 9c:8e:99:4c:13:20 brd ff:ff:ff:ff:ff:ff
inet6 2620:52:0:1040:9e8e:99ff:fe4c:1320/64 scope global dynamic
valid_lft 2592000sec preferred_lft 604800sec
inet6 fec0:0:a10:4000:9e8e:99ff:fe4c:1320/64 scope site dynamic
valid_lft 2592000sec preferred_lft 604800sec
inet6 fe80::9e8e:99ff:fe4c:1320/64 scope link
valid_lft forever preferred_lft forever
3: eno2: mtu 1500 qdisc mq state DOWN qlen 1000
link/ether 9c:8e:99:4c:13:21 brd ff:ff:ff:ff:ff:ff
4: eno3: mtu 1500 qdisc mq state DOWN qlen 1000
link/ether 9c:8e:99:4c:13:22 brd ff:ff:ff:ff:ff:ff
5: eno4: mtu 1500 qdisc mq state DOWN qlen 1000
link/ether 9c:8e:99:4c:13:23 brd ff:ff:ff:ff:ff:ff

[root@70ms ~]# ipa-server-install --setup-dns --no-forwarder -a Secret123 -p Secret123

The log file for this installation can be found in /var/log/ipaserver-install.log
==============================================================================
This program will set up the IPA Server.

This includes:
* Configure a stand-alone CA (dogtag) for certificate management
* Configure the Network Time Daemon (ntpd)
* Create and configure an instance of Directory Server
* Create and configure a Kerberos Key Distribution Center (KDC)
* Configure Apache (httpd)
* Configure DNS (bind)

To accept the default shown in brackets, press the Enter key.

WARNING: conflicting time&date synchronization service 'chronyd' will be disabled
in favor of ntpd

Existing BIND configuration detected, overwrite? [no]: y
Enter the fully qualified domain name of the computer
on which you're setting up server software. Using the form
.
Example: master.example.com.


Server host name [70ms.testrelm.com]:

Warning: skipping DNS resolution of host 70ms.testrelm.com
The domain name has been determined based on the host name.

Please confirm the domain name [testrelm.com]:

The kerberos protocol requires a Realm name to be defined.
This is typically the domain name converted to uppercase.

Please provide a realm name [TESTRELM.COM]:
Do you want to configure the reverse zone? [yes]:
Please specify the reverse zone name [0.4.0.1.0.0.0.0.2.5.0.0.0.2.6.2.ip6.arpa.]:
Using reverse zone 0.4.0.1.0.0.0.0.2.5.0.0.0.2.6.2.ip6.arpa.

The IPA Master Server will be configured with:
Hostname: 70ms.testrelm.com
IP address: 2620:52:0:1040:9e8e:99ff:fe4c:1320
Domain name: testrelm.com
Realm name: TESTRELM.COM

BIND DNS server will be configured to serve IPA domain with:
Forwarders: No forwarders
Reverse zone: 0.4.0.1.0.0.0.0.2.5.0.0.0.2.6.2.ip6.arpa.

Continue to configure the system with these values? [no]: y
The following operations may take some minutes to complete.
Please wait until the prompt is returned.

Configuring NTP daemon (ntpd)
[1/4]: stopping ntpd
[2/4]: writing configuration
[3/4]: configuring ntpd to start on boot
[4/4]: starting ntpd
Done configuring NTP daemon (ntpd).
Configuring directory server (dirsrv): Estimated time 1 minute
[1/38]: creating directory server user
[2/38]: creating directory server instance
[3/38]: adding default schema
[4/38]: enabling memberof plugin

[5/38]: enabling winsync plugin
[6/38]: configuring replication version plugin
[7/38]: enabling IPA enrollment plugin
[8/38]: enabling ldapi
[9/38]: configuring uniqueness plugin
[10/38]: configuring uuid plugin
[11/38]: configuring modrdn plugin
[12/38]: configuring DNS plugin
[13/38]: enabling entryUSN plugin
[14/38]: configuring lockout plugin
[15/38]: creating indices
[16/38]: enabling referential integrity plugin
[17/38]: configuring certmap.conf
[18/38]: configure autobind for root
[19/38]: configure new location for managed entries
[20/38]: configure dirsrv ccache
[21/38]: enable SASL mapping fallback
[22/38]: restarting directory server
[23/38]: adding default layout
[24/38]: adding delegation layout
[25/38]: creating container for managed entries
[26/38]: configuring user private groups
[27/38]: configuring netgroups from hostgroups
[28/38]: creating default Sudo bind user
[29/38]: creating default Auto Member layout
[30/38]: adding range check plugin
[31/38]: creating default HBAC rule allow_all
[32/38]: initializing group membership
[33/38]: adding master entry
[34/38]: configuring Posix uid/gid generation
[35/38]: adding replication acis
[36/38]: enabling compatibility plugin
[37/38]: tuning directory server
[38/38]: configuring directory to start on boot
Done configuring directory server (dirsrv).
Configuring certificate server (pki-tomcatd): Estimated time 3 minutes 30 seconds
[1/22]: creating certificate server user
[2/22]: configuring certificate server instance
[3/22]: stopping certificate server instance to update CS.cfg
[4/22]: disabling nonces
[5/22]: set up CRL publishing
[6/22]: starting certificate server instance
[7/22]: creating RA agent certificate database
[8/22]: importing CA chain to RA certificate database
[9/22]: fixing RA database permissions
[10/22]: setting up signing cert profile
[11/22]: set certificate subject base
[12/22]: enabling Subject Key Identifier
[13/22]: enabling CRL and OCSP extensions for certificates
[14/22]: setting audit signing renewal to 2 years
[15/22]: configuring certificate server to start on boot
[16/22]: restarting certificate server
[17/22]: requesting RA certificate from CA
[18/22]: issuing RA agent certificate
[19/22]: adding RA agent as a trusted user
[20/22]: configure certificate renewals
[21/22]: configure Server-Cert certificate renewal
[22/22]: Configure HTTP to proxy connections
Done configuring certificate server (pki-tomcatd).
Configuring Kerberos KDC (krb5kdc): Estimated time 30 seconds
[1/10]: adding sasl mappings to the directory
[2/10]: adding kerberos container to the directory
[3/10]: configuring KDC
[4/10]: initialize kerberos container
[5/10]: adding default ACIs
[6/10]: creating a keytab for the directory
[7/10]: creating a keytab for the machine
[8/10]: adding the password extension to the directory
[9/10]: starting the KDC
[10/10]: configuring KDC to start on boot
Done configuring Kerberos KDC (krb5kdc).
Configuring kadmin
[1/2]: starting kadmin
[2/2]: configuring kadmin to start on boot
Done configuring kadmin.
Configuring ipa_memcached
[1/2]: starting ipa_memcached
[2/2]: configuring ipa_memcached to start on boot
Done configuring ipa_memcached.
Configuring ipa-otpd
[1/2]: starting ipa-otpd
[2/2]: configuring ipa-otpd to start on boot
Done configuring ipa-otpd.
Configuring the web interface (httpd): Estimated time 1 minute
[1/14]: setting mod_nss port to 443
[2/14]: setting mod_nss password file
[3/14]: enabling mod_nss renegotiate
[4/14]: adding URL rewriting rules
[5/14]: configuring httpd
[6/14]: setting up ssl
[7/14]: setting up browser autoconfig
[8/14]: publish CA cert
[9/14]: creating a keytab for httpd
[10/14]: clean up any existing httpd ccache
[11/14]: configuring SELinux for httpd
[12/14]: configure httpd ccache
[13/14]: restarting httpd
[14/14]: configuring httpd to start on boot
Done configuring the web interface (httpd).
Applying LDAP updates
Restarting the directory server
Restarting the KDC
Restarting the certificate server
CA did not start in 300s

Comment 2 Martin Kosek 2014-03-27 16:45:40 UTC
This seems to me as a DNS resolver configuration issue on given box. /etc/resolv.conf was pointed to IPv4 address which were obviously not reachable and installation was very slow as it timeouted at each bind to `hostname`.

httpd also seemed to have a problem with this setting and refused to bind correctly:

[Thu Mar 27 12:10:07.302065 2014] [proxy:error] [pid 40031] (111)Connection refused: AH00957: AJP: attempt to connect to [::1]:8009 (localhost) failed
[Thu Mar 27 12:10:07.302081 2014] [proxy:error] [pid 40031] AH00959: ap_proxy_connect_backend disabling worker for (localhost) for 60s
[Thu Mar 27 12:10:07.302085 2014] [proxy_ajp:error] [pid 40031] [client 2620:52:0:1040:9e8e:99ff:fe4c:1320:39087] AH00896: failed to make connection to backend: localhost

This lead to IPA server failing to verify that PKI is up even though it should be started (saw "Server is started." in catalina.out):

2014-03-27T16:25:01Z DEBUG Waiting for CA to start...
2014-03-27T16:25:02Z DEBUG request 'https://70ms.testrelm.com:443/ca/admin/ca/getStatus'
2014-03-27T16:25:02Z DEBUG request body ''
2014-03-27T16:25:02Z DEBUG request status 503
2014-03-27T16:25:02Z DEBUG request reason_phrase u'Service Unavailable'

When I updated /etc/nsswitch.conf and disabled dns from "hosts" database:
#hosts:      files dns
hosts: files

the installation went much faster, though it still crashed in the end. I suspected that the issue is similar to Bug 715271, but even if I updated /etc/httpd/conf.d/ipa-pki-proxy.conf to use
ProxyPassMatch ajp://[::1]:8009
instead of
ProxyPassMatch ajp://localhost:8009
I saw no difference.

Rob, any idea how to fix this one?

Comment 3 Rob Crittenden 2014-03-27 17:45:57 UTC
The problem is that tomcat is not binding on the right interface.

From /var/log/pki/pki-tomcat/catalina.out:

Mar 27, 2014 12:19:38 PM org.apache.coyote.AbstractProtocol init
INFO: Initializing ProtocolHandler ["ajp-bio-127.0.0.1-8009"]
Mar 27, 2014 12:19:38 PM org.apache.coyote.AbstractProtocol init
SEVERE: Failed to initialize end point associated with ProtocolHandler ["ajp-bio-127.0.0.1-8009"]
java.net.BindException: Cannot assign requested address /127.0.0.1:8009
        at org.apache.tomcat.util.net.JIoEndpoint.bind(JIoEndpoint.java:406)
        at org.apache.tomcat.util.net.AbstractEndpoint.init(AbstractEndpoint.java:610)
        at org.apache.coyote.AbstractProtocol.init(AbstractProtocol.java:429)
        at org.apache.catalina.connector.Connector.initInternal(Connector.java:981)
        at org.apache.catalina.util.LifecycleBase.init(LifecycleBase.java:102)
        at org.apache.catalina.core.StandardService.initInternal(StandardService.java:559)
        at org.apache.catalina.util.LifecycleBase.init(LifecycleBase.java:102)
        at org.apache.catalina.core.StandardServer.initInternal(StandardServer.java:814)
        at org.apache.catalina.startup.Catalina.load(Catalina.java:665)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
        at java.lang.reflect.Method.invoke(Method.java:606)
        at org.apache.catalina.startup.Bootstrap.load(Bootstrap.java:281)
        at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:455)
Caused by: java.net.BindException: Cannot assign requested address
        at java.net.PlainSocketImpl.socketBind(Native Method)
        at java.net.AbstractPlainSocketImpl.bind(AbstractPlainSocketImpl.java:376)
        at java.net.ServerSocket.bind(ServerSocket.java:376)
        at java.net.ServerSocket.<init>(ServerSocket.java:237)
        at org.apache.tomcat.util.net.DefaultServerSocketFactory.createSocket(DefaultServerSocketFactory.java:55)
        at org.apache.tomcat.util.net.JIoEndpoint.bind(JIoEndpoint.java:396)
        ... 16 more

Which led me to /var/lib/pki/pki-tomcat/conf/server.xml:

<Connector port="8009" protocol="AJP/1.3" redirectPort="8443" address="127.0.0.1" />

I don't see a way to pass in the host in the pkispawn man page.

Comment 4 Martin Kosek 2014-03-28 08:11:30 UTC
Thanks for the pointer, Rob. I did few addition tests on the VM with reproducer and finally made this working with following changes:

sed -i 's/localhost/[::1]/g' /etc/httpd/conf.d/ipa-pki-proxy.conf
sed -i 's/127.0.0.1/::1/g' /var/lib/pki/pki-tomcat/conf/server.xml

... applied during IPA installation:

# ipa-server-install:
...
  [10/14]: clean up any existing httpd ccache
  [11/14]: configuring SELinux for httpd
  [12/14]: configure httpd ccache
  [13/14]: restarting httpd
  [14/14]: configuring httpd to start on boot
Done configuring the web interface (httpd).
Applying LDAP updates
Restarting the directory server
Restarting the KDC
Restarting the certificate server
Configuring DNS (named)
  [1/11]: adding DNS container
  [2/11]: setting up our zone
  [3/11]: setting up reverse zone
...
Be sure to back up the CA certificate stored in /root/cacert.p12
This file is required to create replicas. The password for this
file is the Directory Manager password
# kinit admin
Password for admin@TESTRELM.COM: 
# ipa cert-show 1
  Certificate: MIIDjzCCAnegAwIBAgIBATANBgkqhkiG9w0BAQsFADA3MRUwEwYDVQQKEwxURVNU
UkVMTS5DT00xHjAcBgNVBAMTFUNlcnRpZmljYXRlIEF1dGhvcml0eTAeFw0xNDAz
...
Z7g4OivUabvREXQCVfptBYTUK2OeRYyyvJUA7pWSMOA3x7KUNBw/XyYMO6P7bCYK
dNwqEb9PdjpK10qIfMiFqoY8hMD/UaJm+JaYK1N1q4F12I/ZFhlqMgafvCTarqkg
TI1A
  Subject: CN=Certificate Authority,O=TESTRELM.COM
  Issuer: CN=Certificate Authority,O=TESTRELM.COM
  Not Before: Fri Mar 28 08:00:10 2014 UTC
  Not After: Tue Mar 28 08:00:10 2034 UTC
  Fingerprint (MD5): b9:4b:6f:aa:1b:a3:b4:60:e0:69:91:66:1e:87:cf:c0
  Fingerprint (SHA1): 13:60:34:c0:e1:c0:91:48:30:14:2d:e5:70:08:c8:db:f3:3a:f8:d0
  Serial number (hex): 0x1
  Serial number: 1

Looks as a valid Bug to me then, both in IPA installer and PKI (unless PKI has the aforementioned pkispawn option). I would clone this for PKI as well then.

Comment 6 Ade Lee 2014-03-31 14:49:58 UTC
There is no way to pass that info in using pkispawn.  In fact, that 127.0.0.1 is currently hard coded in the server config.

<Connector port="[PKI_AJP_PORT]" protocol="AJP/1.3" redirectPort="[PKI_AJP_REDIRECT_PORT]" address="127.0.0.1" />

This is actually a change that was made for IPA to restrict AJP to the local host.  Guess we need to be a little smarter on how we do that.  So yes, this is a bug in Dogtag.

Comment 7 Martin Kosek 2014-03-31 15:14:28 UTC
Thanks, cloning this bug PKI as well.

Comment 8 Martin Kosek 2014-03-31 15:16:03 UTC
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/4291

Comment 9 Martin Kosek 2014-04-02 08:10:25 UTC
Until this is fixed, the workaround would be to either modify the files during FreeIPA installation, as mentioned in Comment 4 or by adding IPv4 loopback:

# ip addr add dev lo 127.0.0.1

Comment 10 Rob Crittenden 2014-05-07 12:16:59 UTC
*** Bug 1095025 has been marked as a duplicate of this bug. ***

Comment 14 Martin Bašti 2016-08-25 08:21:22 UTC
Fixed upstream
master:
https://fedorahosted.org/freeipa/changeset/fa3b3193fabcaa37c2ba9865089fcfc06939c77f

Comment 17 Xiyang Dong 2016-09-19 17:17:59 UTC
Verified on ipa-server-4.4.0-9.el7:
[root@mgmt6 ~]# ip addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN qlen 1
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: enp2s3f0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN qlen 1000
    link/ether 00:50:45:5f:41:3c brd ff:ff:ff:ff:ff:ff
3: enp2s3f1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP qlen 1000
    link/ether 00:50:45:5f:41:3d brd ff:ff:ff:ff:ff:ff
    inet 10.16.4.16/22 brd 10.16.7.255 scope global dynamic enp2s3f1
       valid_lft 598559sec preferred_lft 598559sec
    inet6 2620:52:0:1007:250:45ff:fe5f:413d/64 scope global noprefixroute dynamic 
       valid_lft 2591932sec preferred_lft 604732sec
    inet6 fe80::250:45ff:fe5f:413d/64 scope link 
       valid_lft forever preferred_lft forever
[root@mgmt6 ~]# ip addr del 127.0.0.1 dev lo
Warning: Executing wildcard deletion to stay compatible with old scripts.
         Explicitly specify the prefix length (127.0.0.1/32) to avoid this warning.
         This special behaviour is likely to disappear in further releases,
         fix your scripts!
[root@mgmt6 ~]# ip -4 addr del 10.16.4.16/22 dev enp2s3f1

master is getting disconnected after deleting ipv4 addr,
ssh -6 with ipv6 addr from client:

[root@wolverine home]# ssh -6 2620:52:0:1007:250:45ff:fe5f:413d
The authenticity of host '2620:52:0:1007:250:45ff:fe5f:413d (<no hostip for proxy command>)' can't be established.
ECDSA key fingerprint is 95:c6:f5:2e:bf:f9:77:c3:e1:0f:3f:49:79:5d:f7:84.
Are you sure you want to continue connecting (yes/no)? yes
Warning: Permanently added '2620:52:0:1007:250:45ff:fe5f:413d' (ECDSA) to the list of known hosts.
Last login: Mon Sep 19 11:40:23 2016 from vpn-63-226.rdu2.redhat.com
**  **  **  **  **  **  **  **  **  **  **  **  **  **  **  **  **  **
                 This System is reserved by xdong@redhat.com.

 To return this system early. You can run the command: return2beaker.sh
  Ensure you have your logs off the system before returning to Beaker

 To extend your reservation time. You can run the command:
  extendtesttime.sh
 This is an interactive script. You will be prompted for how many
  hours you would like to extend the reservation.

 You should verify the watchdog was updated succesfully after
  you extend your reservation.
  https://beaker.engineering.redhat.com/recipes/3084799

 For ssh, kvm, serial and power control operations please look here:
  https://beaker.engineering.redhat.com/view/mgmt6.testrelm.test

 For the default root password, see:
  https://beaker.engineering.redhat.com/prefs/

      Beaker Test information:
                         HOSTNAME=mgmt6.testrelm.test
                            JOBID=1511446
                         RECIPEID=3084799
                    RESULT_SERVER=[::1]:7093
                           DISTRO=RHEL-7.3-20160916.n.0
                     ARCHITECTURE=x86_64

      Job Whiteboard: IPA :: RHEL 7.3 :: x86_64 :: ipa

      Recipe Whiteboard: Env1 MASTER
**  **  **  **  **  **  **  **  **  **  **  **  **  **  **  **  **  **
[root@mgmt6 ~]# logout
Connection to 2620:52:0:1007:250:45ff:fe5f:413d closed.
[root@wolverine home]# ssh -6 2620:52:0:1007:250:45ff:fe5f:413d
Last login: Mon Sep 19 12:28:41 2016 from 2620:52:0:1060:214:22ff:fe73:5af0
**  **  **  **  **  **  **  **  **  **  **  **  **  **  **  **  **  **
                 This System is reserved by xdong@redhat.com.

 To return this system early. You can run the command: return2beaker.sh
  Ensure you have your logs off the system before returning to Beaker

 To extend your reservation time. You can run the command:
  extendtesttime.sh
 This is an interactive script. You will be prompted for how many
  hours you would like to extend the reservation.

 You should verify the watchdog was updated succesfully after
  you extend your reservation.
  https://beaker.engineering.redhat.com/recipes/3084799

 For ssh, kvm, serial and power control operations please look here:
  https://beaker.engineering.redhat.com/view/mgmt6.testrelm.test

 For the default root password, see:
  https://beaker.engineering.redhat.com/prefs/

      Beaker Test information:
                         HOSTNAME=mgmt6.testrelm.test
                            JOBID=1511446
                         RECIPEID=3084799
                    RESULT_SERVER=[::1]:7093
                           DISTRO=RHEL-7.3-20160916.n.0
                     ARCHITECTURE=x86_64

      Job Whiteboard: IPA :: RHEL 7.3 :: x86_64 :: ipa

      Recipe Whiteboard: Env1 MASTER
**  **  **  **  **  **  **  **  **  **  **  **  **  **  **  **  **  **
[root@mgmt6 ~]# 
[root@mgmt6 ~]# ip addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN qlen 1
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: enp2s3f0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN qlen 1000
    link/ether 00:50:45:5f:41:3c brd ff:ff:ff:ff:ff:ff
3: enp2s3f1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP qlen 1000
    link/ether 00:50:45:5f:41:3d brd ff:ff:ff:ff:ff:ff
    inet6 2620:52:0:1007:250:45ff:fe5f:413d/64 scope global noprefixroute dynamic 
       valid_lft 2591954sec preferred_lft 604754sec
    inet6 fe80::250:45ff:fe5f:413d/64 scope link 
       valid_lft forever preferred_lft forever

[root@mgmt6 ~]# cat /etc/hosts
127.0.0.1   localhost localhost.localdomain localhost4 localhost4.localdomain4
::1         localhost localhost.localdomain localhost6 localhost6.localdomain6
2620:52:0:1007:250:45ff:fe5f:413d mgmt6.testrelm.test mgmt6

[root@mgmt6 ~]# ipa-server-install --setup-dns --no-forwarder --hostname=$(hostname) -r $RELM -n $DOMAIN -p $ADMINPW -a $ADMINPW -UChecking DNS domain testrelm.test, please wait ...

The log file for this installation can be found in /var/log/ipaserver-install.log
==============================================================================
This program will set up the IPA Server.

This includes:
  * Configure a stand-alone CA (dogtag) for certificate management
  * Configure the Network Time Daemon (ntpd)
  * Create and configure an instance of Directory Server
  * Create and configure a Kerberos Key Distribution Center (KDC)
  * Configure Apache (httpd)
  * Configure DNS (bind)

WARNING: conflicting time&date synchronization service 'chronyd' will be disabled
in favor of ntpd

Warning: skipping DNS resolution of host mgmt6.testrelm.test
Checking DNS domain testrelm.test., please wait ...

The IPA Master Server will be configured with:
Hostname:       mgmt6.testrelm.test
IP address(es): 2620:52:0:1007:250:45ff:fe5f:413d
Domain name:    testrelm.test
Realm name:     TESTRELM.TEST

BIND DNS server will be configured to serve IPA domain with:
Forwarders:       No forwarders
Forward policy:   first
Reverse zone(s):  No reverse zone

Adding [2620:52:0:1007:250:45ff:fe5f:413d mgmt6.testrelm.test] to your /etc/hosts file
Configuring NTP daemon (ntpd)
  [1/4]: stopping ntpd
  [2/4]: writing configuration
  [3/4]: configuring ntpd to start on boot
  [4/4]: starting ntpd
Done configuring NTP daemon (ntpd).
Configuring directory server (dirsrv). Estimated time: 1 minute
  [1/47]: creating directory server user
  [2/47]: creating directory server instance
  [3/47]: updating configuration in dse.ldif
  [4/47]: restarting directory server
  [5/47]: adding default schema
  [6/47]: enabling memberof plugin
  [7/47]: enabling winsync plugin
  [8/47]: configuring replication version plugin
  [9/47]: enabling IPA enrollment plugin
  [10/47]: enabling ldapi
  [11/47]: configuring uniqueness plugin
  [12/47]: configuring uuid plugin
  [13/47]: configuring modrdn plugin
  [14/47]: configuring DNS plugin
  [15/47]: enabling entryUSN plugin
  [16/47]: configuring lockout plugin
  [17/47]: configuring topology plugin
  [18/47]: creating indices
  [19/47]: enabling referential integrity plugin
  [20/47]: configuring certmap.conf
  [21/47]: configure autobind for root
  [22/47]: configure new location for managed entries
  [23/47]: configure dirsrv ccache
  [24/47]: enabling SASL mapping fallback
  [25/47]: restarting directory server
  [26/47]: adding sasl mappings to the directory
  [27/47]: adding default layout
  [28/47]: adding delegation layout
  [29/47]: creating container for managed entries
  [30/47]: configuring user private groups
  [31/47]: configuring netgroups from hostgroups
  [32/47]: creating default Sudo bind user
  [33/47]: creating default Auto Member layout
  [34/47]: adding range check plugin
  [35/47]: creating default HBAC rule allow_all
  [36/47]: adding sasl mappings to the directory
  [37/47]: adding entries for topology management
  [38/47]: initializing group membership
  [39/47]: adding master entry
  [40/47]: initializing domain level
  [41/47]: configuring Posix uid/gid generation
  [42/47]: adding replication acis
  [43/47]: enabling compatibility plugin
  [44/47]: activating sidgen plugin
  [45/47]: activating extdom plugin
  [46/47]: tuning directory server
  [47/47]: configuring directory to start on boot
Done configuring directory server (dirsrv).
Configuring certificate server (pki-tomcatd). Estimated time: 3 minutes 30 seconds
  [1/31]: creating certificate server user
  [2/31]: configuring certificate server instance
ipa.ipaserver.install.cainstance.CAInstance: CRITICAL Failed to configure CA instance: Command '/usr/sbin/pkispawn -s CA -f /tmp/tmpiV4_kR' returned non-zero exit status 1
ipa.ipaserver.install.cainstance.CAInstance: CRITICAL See the installation logs and the following files/directories for more information:
ipa.ipaserver.install.cainstance.CAInstance: CRITICAL   /var/log/pki/pki-tomcat
  [error] RuntimeError: CA configuration failed.
ipa.ipapython.install.cli.install_tool(Server): ERROR    CA configuration failed.
ipa.ipapython.install.cli.install_tool(Server): ERROR    The ipa-server-install command failed. See /var/log/ipaserver-install.log for more information


Attached server install log.

Comment 18 Xiyang Dong 2016-09-19 17:29:25 UTC
Created attachment 1202568 [details]
ipaserver-install.log

Comment 19 Petr Vobornik 2016-09-19 18:20:29 UTC
This fails in different step then the initial bug. Could you provide pkispawn log and pki ca debug log?

Comment 20 Xiyang Dong 2016-09-19 19:07:37 UTC
Created attachment 1202615 [details]
pkispawn.log

Comment 21 Xiyang Dong 2016-09-19 19:10:09 UTC
Created attachment 1202616 [details]
pki_ca_debug.log

Comment 27 Xiyang Dong 2017-05-02 05:16:33 UTC
server install went successful with ipa-server-4.5.0-9.el7 :

[root@sparks ~]# ip addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN qlen 1
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: enp2s4: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP qlen 1000
    link/ether 00:14:22:72:f8:c8 brd ff:ff:ff:ff:ff:ff
    inet 10.19.34.87/23 brd 10.19.35.255 scope global dynamic enp2s4
       valid_lft 62993sec preferred_lft 62993sec
    inet6 2620:52:0:1322:214:22ff:fe72:f8c8/64 scope global noprefixroute dynamic 
       valid_lft 2591531sec preferred_lft 604331sec
    inet6 fe80::214:22ff:fe72:f8c8/64 scope link 
       valid_lft forever preferred_lft forever
3: enp3s7: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN qlen 1000
    link/ether 00:0e:0c:9c:ad:93 brd ff:ff:ff:ff:ff:ff
4: enp4s3: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN qlen 1000
    link/ether 00:14:22:72:f8:c9 brd ff:ff:ff:ff:ff:ff
[root@sparks ~]# ip addr del 127.0.0.1 dev lo
Warning: Executing wildcard deletion to stay compatible with old scripts.
         Explicitly specify the prefix length (127.0.0.1/32) to avoid this warning.
         This special behaviour is likely to disappear in further releases,
         fix your scripts!
[root@sparks ~]# ip -4 addr del 10.19.34.87/23 dev enp2s4
[root@sparks ~]# ip addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN qlen 1
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: enp2s4: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP qlen 1000
    link/ether 00:14:22:72:f8:c8 brd ff:ff:ff:ff:ff:ff
    inet6 2620:52:0:1322:214:22ff:fe72:f8c8/64 scope global noprefixroute dynamic 
       valid_lft 2591859sec preferred_lft 604659sec
    inet6 fe80::214:22ff:fe72:f8c8/64 scope link 
       valid_lft forever preferred_lft forever
3: enp3s7: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN qlen 1000
    link/ether 00:0e:0c:9c:ad:93 brd ff:ff:ff:ff:ff:ff
4: enp4s3: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN qlen 1000
    link/ether 00:14:22:72:f8:c9 brd ff:ff:ff:ff:ff:ff
[root@sparks ~]# cat /etc/hosts
::1         localhost localhost.localdomain localhost6 localhost6.localdomain6
2620:52:0:1322:214:22ff:fe72:f8c8 sparks.testrelm.test sparks

[root@sparks ~]# ipa-server-install --setup-dns --no-forwarder --hostname=$(hostname) -r $RELM -n $DOMAIN -p $ADMINPW -a $ADMINPW -U
Checking DNS domain testrelm.test, please wait ...

The log file for this installation can be found in /var/log/ipaserver-install.log
==============================================================================
This program will set up the IPA Server.

This includes:
  * Configure a stand-alone CA (dogtag) for certificate management
  * Configure the Network Time Daemon (ntpd)
  * Create and configure an instance of Directory Server
  * Create and configure a Kerberos Key Distribution Center (KDC)
  * Configure Apache (httpd)
  * Configure DNS (bind)
  * Configure the KDC to enable PKINIT

WARNING: conflicting time&date synchronization service 'chronyd' will be disabled
in favor of ntpd

Warning: skipping DNS resolution of host sparks.testrelm.test
Checking DNS domain testrelm.test., please wait ...

The IPA Master Server will be configured with:
Hostname:       sparks.testrelm.test
IP address(es): 2620:52:0:1322:214:22ff:fe72:f8c8
Domain name:    testrelm.test
Realm name:     TESTRELM.TEST

BIND DNS server will be configured to serve IPA domain with:
Forwarders:       No forwarders
Forward policy:   first
Reverse zone(s):  No reverse zone

Configuring NTP daemon (ntpd)
  [1/4]: stopping ntpd
  [2/4]: writing configuration
  [3/4]: configuring ntpd to start on boot
  [4/4]: starting ntpd
Done configuring NTP daemon (ntpd).
Configuring directory server (dirsrv). Estimated time: 30 seconds
  [1/45]: creating directory server instance
  [2/45]: enabling ldapi
  [3/45]: configure autobind for root
  [4/45]: stopping directory server
  [5/45]: updating configuration in dse.ldif
  [6/45]: starting directory server
  [7/45]: adding default schema
  [8/45]: enabling memberof plugin
  [9/45]: enabling winsync plugin
  [10/45]: configuring replication version plugin
  [11/45]: enabling IPA enrollment plugin
  [12/45]: configuring uniqueness plugin
  [13/45]: configuring uuid plugin
  [14/45]: configuring modrdn plugin
  [15/45]: configuring DNS plugin
  [16/45]: enabling entryUSN plugin
  [17/45]: configuring lockout plugin
  [18/45]: configuring topology plugin
  [19/45]: creating indices
  [20/45]: enabling referential integrity plugin
  [21/45]: configuring certmap.conf
  [22/45]: configure new location for managed entries
  [23/45]: configure dirsrv ccache
  [24/45]: enabling SASL mapping fallback
  [25/45]: restarting directory server
  [26/45]: adding sasl mappings to the directory
  [27/45]: adding default layout
  [28/45]: adding delegation layout
  [29/45]: creating container for managed entries
  [30/45]: configuring user private groups
  [31/45]: configuring netgroups from hostgroups
  [32/45]: creating default Sudo bind user
  [33/45]: creating default Auto Member layout
  [34/45]: adding range check plugin
  [35/45]: creating default HBAC rule allow_all
  [36/45]: adding entries for topology management
  [37/45]: initializing group membership
  [38/45]: adding master entry
  [39/45]: initializing domain level
  [40/45]: configuring Posix uid/gid generation
  [41/45]: adding replication acis
  [42/45]: activating sidgen plugin
  [43/45]: activating extdom plugin
  [44/45]: tuning directory server
  [45/45]: configuring directory to start on boot
Done configuring directory server (dirsrv).
Configuring Kerberos KDC (krb5kdc)
  [1/10]: adding kerberos container to the directory
  [2/10]: configuring KDC
  [3/10]: initialize kerberos container
  [4/10]: adding default ACIs
  [5/10]: creating a keytab for the directory
  [6/10]: creating a keytab for the machine
  [7/10]: adding the password extension to the directory
  [8/10]: creating anonymous principal
  [9/10]: starting the KDC
  [10/10]: configuring KDC to start on boot
Done configuring Kerberos KDC (krb5kdc).
Configuring kadmin
  [1/2]: starting kadmin 
  [2/2]: configuring kadmin to start on boot
Done configuring kadmin.
Configuring certificate server (pki-tomcatd). Estimated time: 3 minutes
  [1/29]: configuring certificate server instance
  [2/29]: exporting Dogtag certificate store pin
  [3/29]: stopping certificate server instance to update CS.cfg
  [4/29]: backing up CS.cfg
  [5/29]: disabling nonces
  [6/29]: set up CRL publishing
  [7/29]: enable PKIX certificate path discovery and validation
  [8/29]: starting certificate server instance
  [9/29]: configure certmonger for renewals
  [10/29]: requesting RA certificate from CA
  [11/29]: setting up signing cert profile
  [12/29]: setting audit signing renewal to 2 years
  [13/29]: restarting certificate server
  [14/29]: publishing the CA certificate
  [15/29]: adding RA agent as a trusted user
  [16/29]: authorizing RA to modify profiles
  [17/29]: authorizing RA to manage lightweight CAs
  [18/29]: Ensure lightweight CAs container exists
  [19/29]: configure certificate renewals
  [20/29]: configure Server-Cert certificate renewal
  [21/29]: Configure HTTP to proxy connections
  [22/29]: restarting certificate server
  [23/29]: migrating certificate profiles to LDAP
  [24/29]: importing IPA certificate profiles
  [25/29]: adding default CA ACL
  [26/29]: adding 'ipa' CA entry
  [27/29]: updating IPA configuration
  [28/29]: enabling CA instance
  [29/29]: configuring certmonger renewal for lightweight CAs
Done configuring certificate server (pki-tomcatd).
Configuring directory server (dirsrv)
  [1/3]: configuring TLS for DS instance
  [2/3]: adding CA certificate entry
  [3/3]: restarting directory server
Done configuring directory server (dirsrv).
Configuring ipa-otpd
  [1/2]: starting ipa-otpd 
  [2/2]: configuring ipa-otpd to start on boot
Done configuring ipa-otpd.
Configuring ipa-custodia
  [1/5]: Generating ipa-custodia config file
  [2/5]: Making sure custodia container exists
  [3/5]: Generating ipa-custodia keys
  [4/5]: starting ipa-custodia 
  [5/5]: configuring ipa-custodia to start on boot
Done configuring ipa-custodia.
Configuring the web interface (httpd)
  [1/21]: stopping httpd
  [2/21]: setting mod_nss port to 443
  [3/21]: setting mod_nss cipher suite
  [4/21]: setting mod_nss protocol list to TLSv1.0 - TLSv1.2
  [5/21]: setting mod_nss password file
  [6/21]: enabling mod_nss renegotiate
  [7/21]: adding URL rewriting rules
  [8/21]: configuring httpd
  [9/21]: setting up httpd keytab
  [10/21]: configuring Gssproxy
  [11/21]: setting up ssl
  [12/21]: configure certmonger for renewals
  [13/21]: importing CA certificates from LDAP
  [14/21]: publish CA cert
  [15/21]: clean up any existing httpd ccaches
  [16/21]: configuring SELinux for httpd
  [17/21]: create KDC proxy config
  [18/21]: enable KDC proxy
  [19/21]: starting httpd
  [20/21]: configuring httpd to start on boot
  [21/21]: enabling oddjobd
Done configuring the web interface (httpd).
Configuring Kerberos KDC (krb5kdc)
  [1/1]: installing X509 Certificate for PKINIT
Done configuring Kerberos KDC (krb5kdc).
Applying LDAP updates
Upgrading IPA:. Estimated time: 1 minute 30 seconds
  [1/9]: stopping directory server
  [2/9]: saving configuration
  [3/9]: disabling listeners
  [4/9]: enabling DS global lock
  [5/9]: starting directory server
  [6/9]: upgrading server
  [7/9]: stopping directory server
  [8/9]: restoring configuration
  [9/9]: starting directory server
Done.
Restarting the KDC
Configuring DNS (named)
  [1/11]: generating rndc key file
  [2/11]: adding DNS container
  [3/11]: setting up our zone
  [4/11]: setting up our own record
  [5/11]: setting up records for other masters
  [6/11]: adding NS record to the zones
  [7/11]: setting up kerberos principal
  [8/11]: setting up named.conf
  [9/11]: setting up server configuration
  [10/11]: configuring named to start on boot
  [11/11]: changing resolv.conf to point to ourselves
Done configuring DNS (named).
Restarting the web server to pick up resolv.conf changes
Configuring DNS key synchronization service (ipa-dnskeysyncd)
  [1/7]: checking status
  [2/7]: setting up bind-dyndb-ldap working directory
  [3/7]: setting up kerberos principal
  [4/7]: setting up SoftHSM
  [5/7]: adding DNSSEC containers
  [6/7]: creating replica keys
  [7/7]: configuring ipa-dnskeysyncd to start on boot
Done configuring DNS key synchronization service (ipa-dnskeysyncd).
Restarting ipa-dnskeysyncd
Restarting named
Updating DNS system records
Configuring client side components
Using existing certificate '/etc/ipa/ca.crt'.
Client hostname: sparks.testrelm.test
Realm: TESTRELM.TEST
DNS Domain: testrelm.test
IPA Server: sparks.testrelm.test
BaseDN: dc=testrelm,dc=test

Skipping synchronizing time with NTP server.
New SSSD config will be created
Configured sudoers in /etc/nsswitch.conf
Configured /etc/sssd/sssd.conf
trying https://sparks.testrelm.test/ipa/json
Forwarding 'schema' to json server 'https://sparks.testrelm.test/ipa/json'
trying https://sparks.testrelm.test/ipa/session/json
Forwarding 'ping' to json server 'https://sparks.testrelm.test/ipa/session/json'
Forwarding 'ca_is_enabled' to json server 'https://sparks.testrelm.test/ipa/session/json'
Systemwide CA database updated.
Adding SSH public key from /etc/ssh/ssh_host_rsa_key.pub
Adding SSH public key from /etc/ssh/ssh_host_ecdsa_key.pub
Adding SSH public key from /etc/ssh/ssh_host_ed25519_key.pub
Forwarding 'host_mod' to json server 'https://sparks.testrelm.test/ipa/session/json'
SSSD enabled
Configured /etc/openldap/ldap.conf
Configured /etc/ssh/ssh_config
Configured /etc/ssh/sshd_config
Configuring testrelm.test as NIS domain.
Client configuration complete.
The ipa-client-install command was successful

==============================================================================
Setup complete

Next steps:
	1. You must make sure these network ports are open:
		TCP Ports:
		  * 80, 443: HTTP/HTTPS
		  * 389, 636: LDAP/LDAPS
		  * 88, 464: kerberos
		  * 53: bind
		UDP Ports:
		  * 88, 464: kerberos
		  * 53: bind
		  * 123: ntp

	2. You can now obtain a kerberos ticket using the command: 'kinit admin'
	   This ticket will allow you to use the IPA tools (e.g., ipa user-add)
	   and the web user interface.

Be sure to back up the CA certificates stored in /root/cacert.p12
These files are required to create replicas. The password for these
files is the Directory Manager password

Comment 28 Petr Vobornik 2017-05-02 08:45:49 UTC
Given that it works (comment 27), moving to modified.

Comment 30 Xiyang Dong 2017-05-02 19:46:56 UTC
Verified on ipa-server-4.5.0-9.el7:
[root@auto-hv-02-guest02 ~]# ip addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN qlen 1
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: ens3: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP qlen 1000
    link/ether 52:54:00:32:f7:3d brd ff:ff:ff:ff:ff:ff
    inet 10.19.34.7/23 brd 10.19.35.255 scope global dynamic ens3
       valid_lft 78357sec preferred_lft 78357sec
    inet6 2620:52:0:1322:5054:ff:fe32:f73d/64 scope global noprefixroute dynamic 
       valid_lft 2591944sec preferred_lft 604744sec
    inet6 fe80::5054:ff:fe32:f73d/64 scope link 
       valid_lft forever preferred_lft forever
[root@auto-hv-02-guest02 ~]# ip addr del 127.0.0.1 dev lo
Warning: Executing wildcard deletion to stay compatible with old scripts.
         Explicitly specify the prefix length (127.0.0.1/32) to avoid this warning.
         This special behaviour is likely to disappear in further releases,
         fix your scripts!
[root@auto-hv-02-guest02 ~]# ip -4 addr del 10.19.34.7/23 dev ens3
[root@auto-hv-02-guest02 ~]# ip addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN qlen 1
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: ens3: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP qlen 1000
    link/ether 52:54:00:32:f7:3d brd ff:ff:ff:ff:ff:ff
    inet6 2620:52:0:1322:5054:ff:fe32:f73d/64 scope global noprefixroute dynamic 
       valid_lft 2591943sec preferred_lft 604743sec
    inet6 fe80::5054:ff:fe32:f73d/64 scope link 
       valid_lft forever preferred_lft forever
[root@auto-hv-02-guest02 ~]# cat /etc/hosts
::1         localhost localhost.localdomain localhost6 localhost6.localdomain6
fe80::5054:ff:fe32:f73d%ens3 2620:52:0:1322:5054:ff:fe32:f73d auto-hv-02-guest02.testrelm.test auto-hv-02-guest02
[root@auto-hv-02-guest02 ~]# ipa-server-install --setup-dns --no-forwarder --hostname=$(hostname) -r $RELM -n $DOMAIN -p $ADMINPW -a $ADMINPW -U
Checking DNS domain testrelm.test, please wait ...

The log file for this installation can be found in /var/log/ipaserver-install.log
==============================================================================
This program will set up the IPA Server.

This includes:
  * Configure a stand-alone CA (dogtag) for certificate management
  * Configure the Network Time Daemon (ntpd)
  * Create and configure an instance of Directory Server
  * Create and configure a Kerberos Key Distribution Center (KDC)
  * Configure Apache (httpd)
  * Configure DNS (bind)
  * Configure the KDC to enable PKINIT

WARNING: conflicting time&date synchronization service 'chronyd' will be disabled
in favor of ntpd

Warning: skipping DNS resolution of host auto-hv-02-guest02.testrelm.test
Checking DNS domain testrelm.test., please wait ...

The IPA Master Server will be configured with:
Hostname:       auto-hv-02-guest02.testrelm.test
IP address(es): 2620:52:0:1322:5054:ff:fe32:f73d
Domain name:    testrelm.test
Realm name:     TESTRELM.TEST

BIND DNS server will be configured to serve IPA domain with:
Forwarders:       No forwarders
Forward policy:   first
Reverse zone(s):  No reverse zone

Adding [2620:52:0:1322:5054:ff:fe32:f73d auto-hv-02-guest02.testrelm.test] to your /etc/hosts file
Configuring NTP daemon (ntpd)
  [1/4]: stopping ntpd
  [2/4]: writing configuration
  [3/4]: configuring ntpd to start on boot
  [4/4]: starting ntpd
Done configuring NTP daemon (ntpd).
Configuring directory server (dirsrv). Estimated time: 30 seconds
  [1/45]: creating directory server instance
  [2/45]: enabling ldapi
  [3/45]: configure autobind for root
  [4/45]: stopping directory server
  [5/45]: updating configuration in dse.ldif
  [6/45]: starting directory server
  [7/45]: adding default schema
  [8/45]: enabling memberof plugin
  [9/45]: enabling winsync plugin
  [10/45]: configuring replication version plugin
  [11/45]: enabling IPA enrollment plugin
  [12/45]: configuring uniqueness plugin
  [13/45]: configuring uuid plugin
  [14/45]: configuring modrdn plugin
  [15/45]: configuring DNS plugin
  [16/45]: enabling entryUSN plugin
  [17/45]: configuring lockout plugin
  [18/45]: configuring topology plugin
  [19/45]: creating indices
  [20/45]: enabling referential integrity plugin
  [21/45]: configuring certmap.conf
  [22/45]: configure new location for managed entries
  [23/45]: configure dirsrv ccache
  [24/45]: enabling SASL mapping fallback
  [25/45]: restarting directory server
  [26/45]: adding sasl mappings to the directory
  [27/45]: adding default layout
  [28/45]: adding delegation layout
  [29/45]: creating container for managed entries
  [30/45]: configuring user private groups
  [31/45]: configuring netgroups from hostgroups
  [32/45]: creating default Sudo bind user
  [33/45]: creating default Auto Member layout
  [34/45]: adding range check plugin
  [35/45]: creating default HBAC rule allow_all
  [36/45]: adding entries for topology management
  [37/45]: initializing group membership
  [38/45]: adding master entry
  [39/45]: initializing domain level
  [40/45]: configuring Posix uid/gid generation
  [41/45]: adding replication acis
  [42/45]: activating sidgen plugin
  [43/45]: activating extdom plugin
  [44/45]: tuning directory server
  [45/45]: configuring directory to start on boot
Done configuring directory server (dirsrv).
Configuring Kerberos KDC (krb5kdc)
  [1/10]: adding kerberos container to the directory
  [2/10]: configuring KDC
  [3/10]: initialize kerberos container
  [4/10]: adding default ACIs
  [5/10]: creating a keytab for the directory
  [6/10]: creating a keytab for the machine
  [7/10]: adding the password extension to the directory
  [8/10]: creating anonymous principal
  [9/10]: starting the KDC
  [10/10]: configuring KDC to start on boot
Done configuring Kerberos KDC (krb5kdc).
Configuring kadmin
  [1/2]: starting kadmin 
  [2/2]: configuring kadmin to start on boot
Done configuring kadmin.
Configuring certificate server (pki-tomcatd). Estimated time: 3 minutes
  [1/29]: configuring certificate server instance
  [2/29]: exporting Dogtag certificate store pin
  [3/29]: stopping certificate server instance to update CS.cfg
  [4/29]: backing up CS.cfg
  [5/29]: disabling nonces
  [6/29]: set up CRL publishing
  [7/29]: enable PKIX certificate path discovery and validation
  [8/29]: starting certificate server instance
  [9/29]: configure certmonger for renewals
  [10/29]: requesting RA certificate from CA
  [11/29]: setting up signing cert profile
  [12/29]: setting audit signing renewal to 2 years
  [13/29]: restarting certificate server
  [14/29]: publishing the CA certificate
  [15/29]: adding RA agent as a trusted user
  [16/29]: authorizing RA to modify profiles
  [17/29]: authorizing RA to manage lightweight CAs
  [18/29]: Ensure lightweight CAs container exists
  [19/29]: configure certificate renewals
  [20/29]: configure Server-Cert certificate renewal
  [21/29]: Configure HTTP to proxy connections
  [22/29]: restarting certificate server
  [23/29]: migrating certificate profiles to LDAP
  [24/29]: importing IPA certificate profiles
  [25/29]: adding default CA ACL
  [26/29]: adding 'ipa' CA entry
  [27/29]: updating IPA configuration
  [28/29]: enabling CA instance
  [29/29]: configuring certmonger renewal for lightweight CAs
Done configuring certificate server (pki-tomcatd).
Configuring directory server (dirsrv)
  [1/3]: configuring TLS for DS instance
  [2/3]: adding CA certificate entry
  [3/3]: restarting directory server
Done configuring directory server (dirsrv).
Configuring ipa-otpd
  [1/2]: starting ipa-otpd 
  [2/2]: configuring ipa-otpd to start on boot
Done configuring ipa-otpd.
Configuring ipa-custodia
  [1/5]: Generating ipa-custodia config file
  [2/5]: Making sure custodia container exists
  [3/5]: Generating ipa-custodia keys
  [4/5]: starting ipa-custodia 
  [5/5]: configuring ipa-custodia to start on boot
Done configuring ipa-custodia.
Configuring the web interface (httpd)
  [1/21]: stopping httpd
  [2/21]: setting mod_nss port to 443
  [3/21]: setting mod_nss cipher suite
  [4/21]: setting mod_nss protocol list to TLSv1.0 - TLSv1.2
  [5/21]: setting mod_nss password file
  [6/21]: enabling mod_nss renegotiate
  [7/21]: adding URL rewriting rules
  [8/21]: configuring httpd
  [9/21]: setting up httpd keytab
  [10/21]: configuring Gssproxy
  [11/21]: setting up ssl
  [12/21]: configure certmonger for renewals
  [13/21]: importing CA certificates from LDAP
  [14/21]: publish CA cert
  [15/21]: clean up any existing httpd ccaches
  [16/21]: configuring SELinux for httpd
  [17/21]: create KDC proxy config
  [18/21]: enable KDC proxy
  [19/21]: starting httpd
  [20/21]: configuring httpd to start on boot
  [21/21]: enabling oddjobd
Done configuring the web interface (httpd).
Configuring Kerberos KDC (krb5kdc)
  [1/1]: installing X509 Certificate for PKINIT
Done configuring Kerberos KDC (krb5kdc).
Applying LDAP updates
Upgrading IPA:. Estimated time: 1 minute 30 seconds
  [1/9]: stopping directory server
  [2/9]: saving configuration
  [3/9]: disabling listeners
  [4/9]: enabling DS global lock
  [5/9]: starting directory server
  [6/9]: upgrading server
  [7/9]: stopping directory server
  [8/9]: restoring configuration
  [9/9]: starting directory server
Done.
Restarting the KDC
Configuring DNS (named)
  [1/11]: generating rndc key file
  [2/11]: adding DNS container
  [3/11]: setting up our zone
  [4/11]: setting up our own record
  [5/11]: setting up records for other masters
  [6/11]: adding NS record to the zones
  [7/11]: setting up kerberos principal
  [8/11]: setting up named.conf
  [9/11]: setting up server configuration
  [10/11]: configuring named to start on boot
  [11/11]: changing resolv.conf to point to ourselves
Done configuring DNS (named).
Restarting the web server to pick up resolv.conf changes
Configuring DNS key synchronization service (ipa-dnskeysyncd)
  [1/7]: checking status
  [2/7]: setting up bind-dyndb-ldap working directory
  [3/7]: setting up kerberos principal
  [4/7]: setting up SoftHSM
  [5/7]: adding DNSSEC containers
  [6/7]: creating replica keys
  [7/7]: configuring ipa-dnskeysyncd to start on boot
Done configuring DNS key synchronization service (ipa-dnskeysyncd).
Restarting ipa-dnskeysyncd
Restarting named
Updating DNS system records
Configuring client side components
Using existing certificate '/etc/ipa/ca.crt'.
Client hostname: auto-hv-02-guest02.testrelm.test
Realm: TESTRELM.TEST
DNS Domain: testrelm.test
IPA Server: auto-hv-02-guest02.testrelm.test
BaseDN: dc=testrelm,dc=test

Skipping synchronizing time with NTP server.
New SSSD config will be created
Configured sudoers in /etc/nsswitch.conf
Configured /etc/sssd/sssd.conf
trying https://auto-hv-02-guest02.testrelm.test/ipa/json
Forwarding 'schema' to json server 'https://auto-hv-02-guest02.testrelm.test/ipa/json'
trying https://auto-hv-02-guest02.testrelm.test/ipa/session/json
Forwarding 'ping' to json server 'https://auto-hv-02-guest02.testrelm.test/ipa/session/json'
Forwarding 'ca_is_enabled' to json server 'https://auto-hv-02-guest02.testrelm.test/ipa/session/json'
Systemwide CA database updated.
Adding SSH public key from /etc/ssh/ssh_host_rsa_key.pub
Adding SSH public key from /etc/ssh/ssh_host_ecdsa_key.pub
Adding SSH public key from /etc/ssh/ssh_host_ed25519_key.pub
Forwarding 'host_mod' to json server 'https://auto-hv-02-guest02.testrelm.test/ipa/session/json'
SSSD enabled
Configured /etc/openldap/ldap.conf
Configured /etc/ssh/ssh_config
Configured /etc/ssh/sshd_config
Configuring testrelm.test as NIS domain.
Client configuration complete.
The ipa-client-install command was successful

==============================================================================
Setup complete

Next steps:
	1. You must make sure these network ports are open:
		TCP Ports:
		  * 80, 443: HTTP/HTTPS
		  * 389, 636: LDAP/LDAPS
		  * 88, 464: kerberos
		  * 53: bind
		UDP Ports:
		  * 88, 464: kerberos
		  * 53: bind
		  * 123: ntp

	2. You can now obtain a kerberos ticket using the command: 'kinit admin'
	   This ticket will allow you to use the IPA tools (e.g., ipa user-add)
	   and the web user interface.

Be sure to back up the CA certificates stored in /root/cacert.p12
These files are required to create replicas. The password for these
files is the Directory Manager password

Comment 31 errata-xmlrpc 2017-08-01 09:37:23 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2304