Bug 1095025 - CA not starting up on IPv6 only system
Summary: CA not starting up on IPv6 only system
Keywords:
Status: CLOSED DUPLICATE of bug 1081561
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa
Version: 7.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Martin Kosek
QA Contact: Namita Soman
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-05-07 01:36 UTC by Michael Gregg
Modified: 2014-08-05 11:18 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-05-07 12:16:59 UTC
Target Upstream Version:


Attachments (Terms of Use)
End of the ipa-sever install log during failed install. (22.23 KB, application/vnd.oasis.opendocument.text)
2014-05-07 01:37 UTC, Michael Gregg
no flags Details

Description Michael Gregg 2014-05-07 01:36:27 UTC
Description of problem:
Attempting to install IPA on a IPv6 only system causes error where CA does not start up.

Version-Release number of selected component (if applicable):
freeipa-server-3.3.5-1.fc20.x86_64
Also seems to apply to the RHEL versions of IPA

How reproducible:
always

Steps to Reproduce:
1. Set up system with only a IPv6 address, no IPv4 addresses
2. Ensure a valid DNS server is in /etc/resolv.conf
3. Ensure that a valid /etc/hosts entry exists.
4. /usr/sbin/ipa-server-install --hostname=<systems valid hostname> -r EXAMPLE.COM -n example.com -p <pw> -P <pw> -a <pw> --ip-address=<IPv6 global address>

Actual results:
Done configuring ipa_memcached.
Configuring ipa-otpd
  [1/2]: starting ipa-otpd
  [2/2]: configuring ipa-otpd to start on boot
Done configuring ipa-otpd.
Configuring the web interface (httpd): Estimated time 1 minute
  [1/13]: setting mod_nss port to 443
  [2/13]: setting mod_nss password file
  [3/13]: enabling mod_nss renegotiate
  [4/13]: adding URL rewriting rules
  [5/13]: configuring httpd
  [6/13]: setting up ssl
  [7/13]: setting up browser autoconfig
  [8/13]: publish CA cert
  [9/13]: creating a keytab for httpd
  [10/13]: clean up any existing httpd ccache
  [11/13]: configuring SELinux for httpd
  [12/13]: restarting httpd
  [13/13]: configuring httpd to start on boot
Done configuring the web interface (httpd).
Applying LDAP updates
Restarting the directory server
Restarting the KDC
Restarting the certificate server
CA did not start in 300s 

Expected results:


Additional info:
I'll attach the end of the ipa install log to this BZ.

Comment 1 Michael Gregg 2014-05-07 01:37:26 UTC
Created attachment 893050 [details]
End of the ipa-sever install log during failed install.

Comment 3 Alexander Bokovoy 2014-05-07 07:44:30 UTC
Could you please provide content of /var/log/pki and /var/log/tomcat.

Comment 4 Rob Crittenden 2014-05-07 12:16:59 UTC

*** This bug has been marked as a duplicate of bug 1081561 ***


Note You need to log in before you can comment on or make changes to this bug.