Bug 1093964

Summary: qtwebkit 32bit package request
Product: [Fedora] Fedora EPEL Reporter: Nux <nux>
Component: qtwebkitAssignee: Rex Dieter <rdieter>
Status: CLOSED CANTFIX QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: unspecified    
Version: epel7CC: constantin_, degts, jreznik, nux, rdieter, than, torriem
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-05-04 18:10:12 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Nux 2014-05-04 01:18:15 UTC
Hello,

Could you guys also build the 32bit version of this package?
Certain applications (such as Skype) require it.

Thanks in advance!

Comment 1 Rex Dieter 2014-05-04 02:28:09 UTC
qtwebkit should be multilib'd already, does this not work?

yum install qtwebkit.i686

Comment 2 Nux 2014-05-04 17:57:02 UTC
It doesn't:

yum --disablerepo=nux-dextop --enablerepo=epel install qtwebkit.i686
Loaded plugins: changelog, langpacks
No package qtwebkit.i686 available.
Error: Nothing to do

I can't find it here either:
http://dl.fedoraproject.org/pub/epel/beta/7/

Had to build it myself in a F19 mock chroot so Skype is usable.

Comment 3 Rex Dieter 2014-05-04 18:09:21 UTC
*** Bug 1094050 has been marked as a duplicate of this bug. ***

Comment 4 Rex Dieter 2014-05-04 18:10:12 UTC
Ah, I think I understand now.

It looks like RHEL7 (and by extention EPEL-7) simply does not support 32bit, the only archs/platforms supported include: x86_64, ppc64

Comment 5 Rex Dieter 2014-05-04 18:20:17 UTC
Asked for clarification on epel devel mailing list:
https://lists.fedoraproject.org/pipermail/epel-devel/2014-May/009522.html

Comment 6 Nux 2014-05-04 18:37:22 UTC
Well, I understand, but closing this bug doesn't make the issue go away.

EL7 is still providing loads of 32bit RPMs, because they know it's needed.

cat /etc/redhat-release 
Red Hat Enterprise Linux Workstation release 7.0 (Maipo)

uname -a
Linux laptopelle 3.10.0-121.el7.x86_64 #1 SMP Tue Apr 8 10:48:19 EDT 2014 x86_64 x86_64 x86_64 GNU/Linux

rpm -qa|grep -c i686
121

Comment 7 Rex Dieter 2014-05-09 16:34:24 UTC
https://lists.fedoraproject.org/pipermail/epel-devel/2014-May/009527.html

"Rhel7 does (support multilib), but there is not enough i686 that epel can do multilib, so epel7 is not going to support multilib at all."

There you have it.

Comment 8 Nux 2014-05-09 16:40:30 UTC
Well, thanks for trying. At least we know something clear. Thanks!

I'll continue to provide my own 32bit package built on F19 for other people.

Comment 9 Rex Dieter 2014-07-09 12:00:18 UTC
*** Bug 1117752 has been marked as a duplicate of this bug. ***

Comment 10 Michael Torrie 2014-08-21 04:01:11 UTC
Very lame. I can understand if it's simply due to lack of manpower.  I was really hoping to use EL7 with EPEL as my desktop OS, but it looks like that might not be possible.  I'll continue to use F19 packages for now, but in the near future that's not going to be viable.  Guess I need to manually build i686 rpms.