Bug 1099498

Summary: Installer shows failure message though everything went well with minor exception
Product: Red Hat Satellite Reporter: Og Maciel <omaciel>
Component: InstallerAssignee: Eric Helms <ehelms>
Status: CLOSED DUPLICATE QA Contact: Katello QA List <katello-qa-list>
Severity: high Docs Contact:
Priority: unspecified    
Version: 6.0.3CC: bbuckingham, ehelms
Target Milestone: UnspecifiedKeywords: Triaged
Target Release: Unused   
Hardware: Unspecified   
OS: Unspecified   
URL: http://projects.theforeman.org/issues/5943
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-06-05 03:23:53 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
katello-installer.log none

Description Og Maciel 2014-05-20 13:18:49 UTC
Created attachment 897572 [details]
katello-installer.log

Description of problem:

For a while now the installer has always shows the following two errors:

/Stage[main]/Candlepin::Database/Postgresql::Server::Db[candlepin]/Postgresql::Server::Role[candlepin]/Postgresql_psql[CREATE ROLE "candlepin" ENCRYPTED PASSWORD 'md5b27d86c15ae303d48c52be1948e49e98' LOGIN NOCREATEROLE NOCREATEDB NOSUPERUSER  CONNECTION LIMIT -1]: Failed to call refresh: Error executing SQL; psql returned 256: 'ERROR:  role "candlepin" already exists
/Stage[main]/Candlepin::Database/Postgresql::Server::Db[candlepin]/Postgresql::Server::Role[candlepin]/Postgresql_psql[CREATE ROLE "candlepin" ENCRYPTED PASSWORD 'md5b27d86c15ae303d48c52be1948e49e98' LOGIN NOCREATEROLE NOCREATEDB NOSUPERUSER  CONNECTION LIMIT -1]: Error executing SQL; psql returned 256: 'ERROR:  role "candlepin" already exists


However, this had not prevented the installer from ending successfully and has been mostly ignored. Yesterday, there were some new changes done to the installer and now these errors cause it to output the following message:

Something went wrong![0m Check the log for ERROR-level output
  The full log is at [1m[36m/var/log/katello-installer/katello-installer.log

The server is up and running but this message is stating the opposite.

Version-Release number of selected component (if applicable):

* apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.9.7-1.el6_5.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.9.7-1.el6_5.noarch
* candlepin-tomcat6-0.9.7-1.el6_5.noarch
* elasticsearch-0.90.10-4.el6sat.noarch
* foreman-1.6.0.8-1.el6sat.noarch
* foreman-compute-1.6.0.8-1.el6sat.noarch
* foreman-gce-1.6.0.8-1.el6sat.noarch
* foreman-libvirt-1.6.0.8-1.el6sat.noarch
* foreman-ovirt-1.6.0.8-1.el6sat.noarch
* foreman-postgresql-1.6.0.8-1.el6sat.noarch
* foreman-proxy-1.6.0.5-1.el6sat.noarch
* foreman-selinux-1.6.0-2.el6sat.noarch
* foreman-vmware-1.6.0.8-1.el6sat.noarch
* katello-1.5.0-24.el6sat.noarch
* katello-ca-1.0-1.noarch
* katello-certs-tools-1.5.5-1.el6sat.noarch
* katello-installer-0.0.40-1.el6sat.noarch
* openldap-2.4.23-32.el6_4.1.x86_64
* pulp-katello-plugins-0.3-1.el6sat.noarch
* pulp-nodes-common-2.4.0-0.16.beta.el6sat.noarch
* pulp-nodes-parent-2.4.0-0.16.beta.el6sat.noarch
* pulp-puppet-plugins-2.4.0-0.16.beta.el6sat.noarch
* pulp-puppet-tools-2.4.0-0.16.beta.el6sat.noarch
* pulp-rpm-plugins-2.4.0-0.16.beta.el6sat.noarch
* pulp-selinux-2.4.0-0.16.beta.el6sat.noarch
* pulp-server-2.4.0-0.16.beta.el6sat.noarch
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-ldap_fluff-0.2.2-2.el6sat.noarch
* ruby193-rubygem-net-ldap-0.3.1-3.el6sat.noarch
* ruby193-rubygem-runcible-1.1.0-2.el6sat.noarch
* rubygem-hammer_cli-0.1.0-13.el6sat.noarch
* rubygem-hammer_cli_foreman-0.1.0-13.el6sat.noarch
* rubygem-hammer_cli_foreman_tasks-0.0.2-6.el6sat.noarch
* rubygem-hammer_cli_katello-0.0.3-24.el6sat.noarch

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 Brad Buckingham 2014-05-27 15:18:05 UTC
Created redmine issue http://projects.theforeman.org/issues/5943 from this bug

Comment 3 Eric Helms 2014-06-05 03:23:53 UTC

*** This bug has been marked as a duplicate of bug 1072708 ***